Typing error with Korean

Hello, I’m anki user from S.Korea.
I usually study with korean text and I’ve been experiencing typing error on it.

When I type korean at Front space and then press ‘tab’ for move to Back space, what I typed in Front text is deleted(not all, just last one).

And second problem is typing with !@#$%^&*()_+,.;'/ (i dont know what it’s called).
As same issue like above when I type korean and then put those text, last text is deleted.
for example: 한국어. → 한국 / 복초(服招) → 복초服招)

with these problem, I’m very stressful to study… so hope to solve it as soon as possible.

is there anyone who can advise??

I’ve tried to update newest version, reinstall, changed system language from mac and Anki to Koeran, turning off keyboard-text options.

by the way, I’m using Anki on Mac OS.

I can’t seem to reproduce this, but you can probably work around it for now on your system by using the Qt5 version of 2.1.54.

1 Like

Same problem occurs to me as well after the update. Whenever I type korean there is an underline, and the underlined letter gets erased whenever I type ()!@#$% afterward. Haven’t tried downgrading yet, I wonder if addons and addons settings are preserved after the downgrade?

1 Like

I can’t reproduce it on my Mac either. Did you try check if an add-on is causing this by turning off all your add-on?

Add-ons are preserved when you downgrade, but you might need to re-download some that have different files for 2.1.50+. If you downgrade, I recommend 2.1.49.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.