Type-in-the-answer card blows away <hr id=answer> <br> formatting?

My cards format fine when I am studying them. That is they do until I study a type-in-the-answer card. That card formats and works fine. But in all the cards with standard

layouts on the answer side that I study after it, the formatting is bad. The horizontal line is not present and there are no line feeds between the {{FrontSide}} and the answer field. Restarting Anki solves the problem, but only until I get to a type-in-the-answer card again.

The formatting problem appears to be consistent. I.e., it happens each time. It’s not intermittent. It occurs when Anki is started with shift held down, i.e., when add ons are not loaded.

You should check your card templates from Tools > Manage Note Types, select Basic (type in the answer) and click Cards... and make sure your back template looks something like this:


<hr id=answer>


I did check that, and all is well. Keep in mind that the same cards behave differently depending upon whether they are studied before or after the type-in-the-answer card is studied.

Please upload a small .apkg file with only a few cards that demonstrates the problem.

Pardon me for being slow, but I can’t find instructions on how to upload a file here.

I think users can only attach pictures for t now. There is the error message I get when trying to upload a deck file:
Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif).


Yes, that’s the message that I got when I tried to drag and drop the file I wanted to upload.

you can use gofile.io to upload.
it’s easy to use, you don’t need to zip files to upload and no registration is required

@mmdg2 Thanks for the suggestion.

@dae Here’s the gofile.io link: https://gofile.io/d/QjMSSG .

everything seems to be working fine.

can you post a screenshot or a video of the exact problem?

I think that a video would be most useful. How do I make one?

if you’re on windows 10 you can use microsoft game bar (windows+G)
you can also use a software for that, there should be a bunch of free softwares for screen recording.

video plus some images: https://gofile.io/d/F4gj2D

did exactly as you did, still working fine :confused:
if you’re 100% sure no add-on is doing weird stuff, update your anki to the latest version.

if you’ve already have tried both, i have no idea what might be causing this

@dae might be able to help you solve this. he asked for the files 3 days ago, so once he tests it, hopefully he’ll help you solve this.

1 Like

It’s an add-on. I wasn’t holding the shift key down hard enough or maybe not long enough. In any event, I didn’t notice that add-ons were still being loaded. Now that I have excluded them, I don’t have the problem. Weird.

now you can find the add-on by disabling add-ons one by one (or if you know what add-on messes with the cards and templates, start with them first). once you found it, you can report the problem to the add-on author and disable it till they fix it.


Yes. I’ll start that process now. Frustrating, but step by step!

I found the problem add-on, and I’ve informed its author. Quick question in case I ever have to do this again: Is it enough to disable an add-on and continue testing, or must I first close and re-open Anki after disabling the add-on?

you should close and re-open anki after disabling the add-on

Thought so. That’s what I did. Just hoping to save some work in the future!

I suggest that the need to restart be added to the FAQ’s When problems occur write up at Item 4. It would clarify matters.

Thanks for all your help. It’s much appreciated!

1 Like