Type-in field does not display during Study

I am trying to create a type-in-answer card. Everything appears normal in the Preview, but Study does not show the type-in field. There are many posts about this on reddit and AnkiForums, all without a solution. I am running 2.1.61 qt6 on a desktop PC with Ubuntu 22.04. There are no add-ons and no changes in CSS.

My front template is:

My back template is:

{{type:answer}} {{present}}

I found a workaround, but it should not be necessary. If I put a space into the answer field on every card, then the field will appear during Study. There are several posts in reddit which mention something about an option to force the display of the type-in field, but those posts refer to older versions of Anki; no such option appears in 2.1.61. Even the type-in video referenced in docs dot ankiweb dot net is old. Also, even with the workaround, the backside of the card will not indicate errors in the answer, as depicted in several (old) YouTube videos on the type-in card.

The type-in-the-answer feature is intended to compare your input to the contents of a field. If the field is empty, it’s not shown, as there’s nothing to compare.

Thank you for responding.

I cannot get this to work. I cannot find a working example in the User Guide or online. Could you please provide a sample note and just one card?

You can use file>switch profile to create an empty test profile, then add a card with non-empty front and back using the ‘basic (type in the answer)’ notetype to see how it should work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.