Trouble Uploading Deck to AnkiWeb Due to Large Collection File Size

Hello Anki community,

I’ve been experiencing an issue when trying to upload my deck to AnkiWeb. Even after deleting most of the decks from my collection, I still receive the following error message:

“Your collection file is too large to send to AnkiWeb. You can reduce its size by removing any unwanted decks (optionally exporting them first), and then using Check Database to shrink the file size down. (⁨423919616 > 314572800⁩)”

I have already tried the suggested steps, such as exporting and removing unwanted decks, and using the “Check Database” function, but the issue persists.

Could anyone please advise me on how to resolve this problem? I would appreciate any suggestions or guidance on how to successfully upload my deck to AnkiWeb without encountering this error.


You appear to have some large images embedded in your notes, instead of them being stored in your media folder. If you search for ‘base64’, you can locate them. Do you know how the images got there? Did you add them using one of the Anki clients, or were they from a shared deck?

After you’ve identified them, you should be able to use this add-on to move them to your media folder, and then check database should shrink your collection down.

Thank you for your reply and helpful suggestion!

Regarding searching for ‘base64’, should I do this in the card browser? As for the large images, I didn’t import any shared decks, but the issue seemed to have arisen after an update to the AnKing note type.

In addition, wanted to mention that I’m facing difficulty searching in the browser, as it becomes extremely laggy, forcing me to quit Anki to continue using it. Could this lag be related to the presence of large media files in my collection?

I appreciate your assistance and look forward to your guidance on how to proceed.

Yes, please search in the browser. The large images have most likely caused the slowdowns you’re experiencing.

@AnKingMed is it possible AnkiHub has caused this?

Not that I’m aware of. @stevenyu are you using AnkiHub? If so, what decks are you subscribed to? If you identify any notes with base64 please put the note IDs here so I can look into it

Thank you for your answer, I tried to localise media of all cards after searching ‘base64’ but it pop out this message.

I truly appreciate your help.

@andrewsanchez looping you in

You should be able to fix that by searching for using find and replace to find\d+/ and replacing it with nothing, making sure ‘regular expression’ is enabled. Then you should be able to localize media. It should bring your collection down to about 22MB after a DB check.

Anki shouldn’t be allowing you to paste links like that into fields though, so I’m wondering how this has happened. Do you use an add-on that alters the way pastes are handled for example?

1 Like

Thank you so much for your help! I followed your advice to use find and replace with the regular expression you provided, and it successfully solved my problem. I really appreciate your assistance, and I’m glad my Anki collection is now down to a more manageable size and I can sync it!!!

As for your question about add-ons, I’m not aware of any add-on that I’m using that alters the way pastes are handled in Anki. The photo is the add-on that I used. The issue happen after the anking note type update recently but Im not sure is it related to the problem.

Once again, thank you for your invaluable help. Have a great day!

@abdo @risingorange any chance this is related to the note types?

1 Like

Glad to hear that’s resolved your issue!

My odds would be on it not being related to notetypes. It’s possible the issue occurred some time ago, and has not been noticed until now. I recommend doing the occasional search for base64 and If you find either crop up again in the future, please try to narrow down what’s causing it.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.