Tooltip hover appearance looks strange

Hey all,

I noticed that the tooltip when hovering over the toolbar buttons look a bit strange. It seems like this issue was introduced in 2.1.62 with “Improve hover appearance of buttons”. Could this be some sort of GTK theme issue?


Extra info:

Version <U+2068>2.1.63 (f356f177)<U+2069>
Python 3.9.15 Qt 6.5.0 PyQt 6.5.0
  • Tested with all add-ons disabled
  • Also reproduced in the 2.1.64rc1
  • Also reproduced with minimalist mode turned off
  • OS: Xubuntu 20.04

I can’t seem to reproduce this on a Linux system here. I tried both light and dark mode, and both native and Anki styles. Maybe something specific to your system’s Qt theme?

Just tried native and Anki styles, and it still looks too bright on my machine.

It could be something strange with my Qt theme, but I unfortunately don’t have the knowledge to properly debug it. My guess is that 20.04 is getting a bit outdated, so things are ever so slowly breaking here and there, and this is just one of those issues. Whenever I get to updating my OS, I’ll check again and hopefully be able to play around with stuff like qt6ct.

Until then, unless someone else has the issue and can reliably provide reproduction steps, it should be safe to mark this as won’t fix / cannot reproduce. Thanks again for the response!

1 Like

I’m seeing this problem on Ubuntu 22.04 as well.

Version ⁨2.1.64 (581f82c5)⁩
Python 3.9.15 Qt 6.5.0 PyQt 6.5.0

I’ve seen this with 2.1.63 and 2.1.64, but it may well be older. As far as I can tell, light mode / dark mode, style (native / anki) or UI language don’t seem to make a difference.

EDIT: I recently got a new machine and had some problems to install Anki on it, until I found that I needed to install libxcb-cursor0 (hxxps:// Maybe this is a similar problem, that there’s some part of Qt, some font or something that Anki relies on for the tooltip and that’s not installed in Ubuntu by default.

I just installed Ubuntu 22.04 and ran the packaged version of Anki, and the tooltips looked correct for me. I assume you guys are not using a Flatpak/Snap, and have all add-ons disabled?

The packaged version of Anki in Ubuntu 22.04 is 2.1.15, which is relatively old. I’m using the current version 2.1.64, installed by sudo ./ Deactivating all extensions doesn’t seem to make a difference, the tooltips are still illegible.

I assume you restarted Anki after disabling them, or started with the shift key? Have you customized the default theme of Ubuntu?

A simple solution is likely to upgrade to a newer version of the operating system. If you choose a rolling-release distro, it will have a newer package available in the repositories, such as anki in the AUR which is currently at 2.1.64.

@tatsumoto Henning.K seems to be using the latest stable (LTS) version of Ubuntu, so there doesn’t seem like something to update to past that unfortunately.

@dae Just like Henning.K, I’ve been using the standard sudo ./ method, and at least for me, I held down shift when starting up Anki.
I did modify the default theme using qt5ct to adwaita-dark (installed from sudo apt install adwaita-qt) a while ago. Since it’s Qt5, I’m not sure if it has any actual effect though.

I was able to reproduce it after switching the system to dark mode, and a fix will be in the next update.


Just tested the 2.1.65 release candidate, and it was fixed on my end. Thank you so much!

1 Like

I’m afraid I still see the problem with the latest release

Version ⁨2.1.65 (aa9a734f)⁩
Python 3.9.15 Qt 6.5.0 PyQt 6.5.0

Deactivating any extensions doesn’t seem to make a difference. I’ve tried restarting Anki, restarting the session (logging out and logging in again) and restarting the machine.

Is there something I could try to further debug the problem?

Since it works for me on a stock 22.04 install, perhaps you have changed the system theme in the past to something else?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

I’d prefer not to open a new topic whenever I need to come back to this issue, but the last one has been automatically closed since. Maybe @dae or somebody else can combine the topics, also including the original one?

As mentioned on GitHub ,

Please report any improvements or regressions you notice, as we need to decide whether to (partially) revert this before the stable release.

so I can report that the tooltips in Anki 23.10.1rc1 are fine and legible. The problem still occured in 23.10, but no longer in the latest RC.

Thanks for letting me know!