TImezone handling error; unable to sync at all

Having a bit of a panic attack because I can’t seem to solve this problem:

“Your Anki client does not support the new timezone handling yet. Please switch to the legacy handling in the computer version’s Preferences screen”

This is the error message I’m getting. The problem is, when I go to my preferences screen, there is no option for me to switch to the legacy timezone handling. I have a Mac; I’ve seen other posts that describe how to fix this issue, but they are regarding androids.

I’m now at the point where I cannot sync between my Mac and phone at all, and am really worried about losing my decks and data.

No need to panic, the issue can likely be resolved. If you’re not seeing such a setting in the preferences screen, you’ll need to make sure you’re running a recent Anki version, and have updated to the v2 scheduler if prompted by a message at the top of the deck list.