Target deck not updating when clicking Add

Hi everyone,

Something strange is happening recently in Anki Desktop and Anki on my iPhone. When I click on a Deck and then click Add, the target deck given on the top right next to Deck is not the deck which I just clicked on, but the last deck for which I added a card.

For example, here I clicked on Croatian: Verbs. The menu changes for being in the deck (Congratulations! You have finished… etc. screen). I then click add. But instead of target deck being Croatian:Verbs as expected, and as the behavior since forever, It shows Croatian: Nouns which is the last deck I added a card to (image 1)

A further example, again the same problem (image 2)

I don’t understand this. It has always worked such that, when I click on a deck, click Add, the card I’m creating will then be added to that deck I just selected without me having to update anything further. That is my workflow. But It seems this doesn’t work anymore, it just stays stuck on the last deck for which a card was added.

In the preferences screen, there is an option that controls whether the current deck, or deck from the current notetype is used by default.

1 Like

Hi thank you for your respone. The current setting with this problem looks like.
I then changed it to “When adding, default to current deck”. That solved the issue. But I’m still not sure why it randomly changed at some point in the last week. Whatever :slight_smile: it works again. Thanks!

It could be that it reset after updating? I think I did update in the last couple weeks. Maybe it went back to a default value?

The default is to use the current deck, so I can’t think of a reason Anki would have changed the value on you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.