Syncing issue with Ankidroid


When I try to sync on Ankidroid it requires me to first “Check database”. After it has checked database, it requires me to do a full sync. It does this everytime I try to sync. I have done several full syncs in both directions, I have tried to re-install the app, but nothing helps.

The issue suddenly appeared yesterday, on two different Android devices, both running the latest version of Ankidroid, which is why I’m thinking the problem is probably not coming from the app? I can’t remember having done anything different before the problem appeared.

Edit: Syncing on desktop works as normal.

Very grateful for any help on this!

If a check database on AnkiDroid followed by an upload causes the same problem, please report the issue to the AnkiDroid developers with a link to this: Anki-Android/ at 7082f6ee93ed165180b935dbca44598a6566b3cc · ankidroid/Anki-Android · GitHub


Okay, I will do so then, thanks for your reply!

Hey @dae - just curious if you had specific information that led you to that line of the sanity check or is it an informed guess of some sort? We have the user collection now and I can start picking at it but if you have any context it might speed up the issue. We’re drowning a bit with Google Summer of Code work right now so time is tight and I’ll look for any acceleration I can get at the moment. Thanks!

@MikeHardy that’s the specific error this user was getting

@Calle my earlier reply may have been unclear. After using Tools>Check Database, did you go into the preferences screen and force a one-way sync, then sync and choose Upload? If not, please do so and see if that helps.

1 Like

Ah, okay, I didn’t fully get that. And it actually seems to have worked, thank you so much @dae !!

And thank you too @MikeHardy for looking into the problem!

So, it seems solved for now. Thank you so much for your help, and thank you for running the best study app there is!