Syncing bug on iphone

Is this the new place to report bugs? It’s a bit unclear.

I’m on an iPhone fully updated OS fully updated Anki. Even an hour ago no issues syncing. I used Anki on my Mac, fully updated OS, Anki is not fully updated though it’s a relatively recent version, 2.1.something. Just now synced on desktop without issue, then went to sync on my iPhone and got this error. Any thoughts? I’ll try a full sync on my phone, but my collection is fairly large. Regardless seems like a dangerous sort of issue if it’s not isolated to something weird about my deck.

Tried to do a full sync (though haven’t tried deleting all my data…) and got this:

I’m able to access abkiweb fine so really hoping my data isn’t corrupted

Third time’s the charm on my phone. That’s a good sign! Still, seems like maybe some error handling it some code path is not correct.

And after working multiple times, got the original error again!

This message indicates some of your review history has been written in the wrong format by a previous bug in the v2 scheduler, or an add-on. Please use the check database feature in the preferences screen which should fix the problem, then upload your collection to AnkiWeb and download it on your other devices.

I’d also recommend updating to the latest computer version, as the fact that this error came back after a full sync indicates that your computer version is still writing data in the wrong format as you review cards on it.


Updating to the newest computer version seems to have worked. Also wow must have been longer than I thought, maybe 2.0.x… post update it’s very responsive! (Though my saved search strings are all broken lol)

Glad to hear the speed improvements are noticeable!