Error Searching

Hello. I was having troubles with my AnkiMobile since the very last update. I keep on getting annoying errors regarding “database searching”, it keeps popping up during sync, review process and even when I edit cards. Database has been checked already, deck was forcedly reuploaded to AnkiWeb many times to ensure there are no problems with my collection. The collection itself hasn’t dramatically changed, but the update itself seemed to have broken the app for me. Sorry, that’s all the information I can provide though I understand it might be insufficient.

This error might indicate that you have a filtered deck configured to use an invalid search. If that’s the case here, the error will go away if you delete the filtered deck or fix its search setting.

It is weird, because I don’t have one. None of my current decks is filtered.

Do you have a custom search filter selected in the statistics screen?

Seems standard unless there are options I could have missed, seems normal.

@dae, could this be any internal search causing the error?

The daily unburying uses a search internally, and I’m wondering if this message is actually masking some sort of corruption in your collection. You said the database check doesn’t report any issues? Does your device have free storage space? Does restarting your device make any difference?

Restarting device didn’t help me, checking database fixed just one invalid property. And there is free space of 70GB on my device. And yes, I use “bury related notes” option, which has been working normal (hasn’t caused a single error) for months prior to last two updates (~2 and ~3 weeks ago respectively).

Ok, we’ll need to dig further into this. I’m currently waiting for Apple to approve a minor bugfix update that would be a good next thing to try; it should be ready in about a day, and I’ll let you know.

The update is now available for download on the app store. Do you problems persist after updating? If so, please drop me a line on and I’ll send you a beta invite.

I could reply in a couple of days from now if something breaks for me, but I haven’t encountered a single error after using updated version for 1.5 hours today, so it seems like the problem is gone. Thanks!

Error has just occurred. :frowning:

Do you remember the steps that triggered it? If you force the app closed and restart, does it come back immediately, or after taking certain actions?

I’ll dig through the code some more and send a new beta to Apple; it may take them a day or two to approve it.

I tried to intentionally cause the error, but nothing succeeded for a period of time. Then (as you could see on screenshot) it was triggered during the review, the second time it triggered for me yesterday is when I was in editing screen, correcting my note. Before that, I got this error in the statistics screen and during synchronization. I could say the place where the error is shown to me is quite arbitrary each time.

I have the same error appearing more and more often lately.

I believe this has been fixed - it turned out to be related to viewing the graphs screen. Please let me know if you’d like to try the beta version with a fix: Beta Testing - AnkiMobile Manual