Straight Reward [Official support]

From The 2021 scheduler - Frequently Asked Questions

Go back to the v2 scheduler and see if it works again

Yes it works with v2, I’m waiting for a v3 update :smiley:

I haven’t really had a look into this, but I assume that you now can accomplish the things I did with Straight Rewards entirely in the new Deck options under Custom scheduling - in a cross-platform compatible way.

I hope you can help us code it under Custom Scheduling :slight_smile: @hengiesel

Would it be something like this?

// increase ease factor by 0.05 when Good used on a review
if (states.good.normal.review.easeFactor<2.50) {
states.good.normal.review.easeFactor =
states.hard.normal.review.easeFactor + 0.2;
}

I think it’s working, but I don’t know what kinda of bugs I just introduced.

1 Like

@hengiesel

Please explain to me how to set “Straight Reward”.

I have these settings:

and example card history is like this:

I hit “Good” 5 times and it says I gained 70 Ease Factor but ease remains 180%.

First of all where I set after how many times this add-on starts to change ease? Is 6 times, as in an example:

You rated a card “Good” for the sixth time in a row.

a default value?

How I wish it would work:

My highest ease is set to 250%.

I choose that after 2 times I hit “Good” it changes ease by 15%. The next time I hit “Good” it changes ease by next 15%, and so on, so when I start from ease 180 I need 2 times plus 180+( 5 x15)=255 = 7 times to reach 250% ease.

Is it possible to set this add-on like this? Or in other way to achieve similar result.

I don’t quite understand terms “base reward”, “step reward” and whether there is a difference between “ease factor” and “ease” as given in Anki statistics.

Does the count starts from installation of add-on or it takes into account card history.

If in a given example I had 5 times good why nothing changed?

I don’t understand the settings of this add-on. To me it could work in a simple way. If I hit a certain amount of “Good” button, which is taken from card history, it treats the “Good” button as “Easy” button, until set ease for example 250% is reached. Can your add-on be simplified to work like this?

I am on Anki Version ⁨2.1.43 with v2 scheduler and it doesn’t work at all even with default settings. Even with Begin at straight of length:1.

If we use the default settings:
Begin at straight of length: 2
Base Reward: 5%
Step Reward: 5%
Start at ease: 130%
Stop at ease: 250%

My example:

Let’s say starting at 230%
Good → 5% + 5%(1-2) = 0 → 230%
Good → 5% + 5%
(2-2) = 5% → 235%
Good → 5% + 5%(3-2) = 10% → 240%
Good → 5% + 5%
(4-2) = 15% → 245%
Good → 5% + 5%*(5-2) = 15% → 250%

Technically pressing good 4 times to recover from hard (as hard lessens ease by 15%)
Technically pressing good 5 times to recover from ease (as ease lessens ease by 20%)

Am I correct in my calculations and conclusion?

(post deleted by author)

Not sure about how the Custom Scheduling works, but I’d at least add a Math.min so that it doesn’t go higher than 2.50.
Your current code could for example bump the ease from 2.45 to 2.65.

Hi!
The AddOn loks exaclty like what I’m looking for, and wanted to try it… but is it actually working? Attaching 3 screenshots that show that the ease doesn’t get the bonus declared by the pop-up. It stays the same when I press Good, and goes up only by the default 15% when I press Easy.

I’m using the Windows desktop app, ⁨version 2.1.49 (dc80804a)⁩



Thanks,
Bartek

Hi @carlos1172, thank you for your code suggestion! How’s it working so far for you?

It’s working great as of 2.1.49

1 Like

Hello,

Is there a way to change the position and the duration of the pop-up notification?
I tried checking the addon’s files, but I could not find a solution.
(reason I’m asking: since I updated to Anki 2.1.49 the pop-up notification appears only for a small fraction of a second and it’s very easy to miss it)

Thank you

It seems to be not working currently, I am not sure why. I don’t know if it is interacting with some add on or if it just simply stopped working.
It only happens with manual sync

Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeat until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site.
Debug info:
Anki 2.1.49 (dc80804a) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2022-03-17 07:21:32

Caught exception:
Traceback (most recent call last):
File “aqt\taskman.py”, line 101, in on_closures_pending
File “aqt\taskman.py”, line 71, in
File “aqt\taskman.py”, line 90, in wrapped_done
File “aqt\sync.py”, line 101, in on_future_done
File “anki\dbproxy.py”, line 35, in begin
File "anki_backend_init
.py", line 86, in db_begin
File “anki_backend_init_.py”, line 101, in _db_command
anki.errors.DBError: DbError { info: “SqliteFailure(Error { code: Unknown, extended_code: 1 }, Some(“cannot start a transaction within a transaction”))”, kind: Other }

In Anki 2.1.50, in the parameters screen, after installing the addon, it is configured with the value “1”, but Anki shows that the DEFAULT is “2” and in the tutorial it says that it is “0”.

What default value?

image

This add-on looks perfect for my needs, but does it handle “Review” and “Relearn” rating types differently?

For instance, I have 6 relearning steps and I don’t really want to start repairing the ease until those steps are finished, but on the other hand, I don’t want to perform 7 reviews before getting the reward, if I only answered hard once and didn’t need to go through the relearning steps again.

Thanks!

How do I verify that the add-on is working correctly? I’m on 2.1.49/macOS/v3 scheduler and I have my doubts.

Steps to reproduce:

  1. Review card → note notification of reward applied “Succeeded 3 times in a row. Reward of 13…”
  2. Note previous ease of 250%
  3. Go to browser, check that card id. Note current ease of 250%
  4. Quit Anki and restart
  5. Check card id. Note ease still reported as 250%.
  6. Quit Anki
  7. Open collection sqlite db and query cards table for the card id in question. Note factor column still 2500.

If the reward of 13% had been applied, shouldn’t the current ease be 263%?

[LATER] - turned OFF the V3 scheduler - and now it works as intended.
[LATER STILL] - uninstalled Straight Reward add-on and reinstalled to confirm latest version. Turned ON V3 scheduler. Now rewards do not work again. Conclusion: the add-on does not work with V3 scheduler in 2.1.49. Is this correct?

Correct, I’ve packed the update for 2.1.50 and support for v3 together, so no v3 support in 2.1.49

Relearning cards do not get ease bonus.

The default is 2. Hm, I don’t think this options screen works for rewards however. To make sure, use the old options screen by shift-clicking the options button.

Really.
The old screen shows “2”.
The new show “1”.

Would you please add v3 support in 2.1.49? I have a Windows 7 machine I plan on using for a while and I would really like to be able to use your addon + v3 on it

If you want, we can also discuss a price

Sorry, time is the issue, not money. PRs welcome.

2 Likes