Static on recording


I have tried recording my voice for my cards and at first the recordings were clear, I have 3 successful recordings. Then after a little while a static background noise was present on new recordings.

I am recording on a laptop. Using built-in mic. Have latest download of Anki. I have a new laptop, Windows 11, i7.

I tried; restarting computer; recording while charging; recording going without powered laptop at 100% charge, recording in another room, recording on another day when laptop has just opened. Switched off all other appliances.

Reducing the sound volume (20) while recording reduces the static, however still not a clear recording, if previewing card the static increases when you turn the volume up. So, this doesn’t solve the problem. (This doesn’t happen with the three successful recording, adjusting volume to 100 still has a clear audio - no static.)

Initial successful recordings were done when battery was low but had no trouble recording - no static background noises, and I had a word document and internet browser running in the background. I don’t understand why it worked then but stopped working — that is started recording a static sound.

[I can’t hear any background sound in the room from any other appliances that could be the problem.]

I put my mobile in another room.

This sounds more of like a hardware problem than an Anki problem. I didn’t see anything in your description that sounded like Anki could be at fault, so I doubt anyone here would be able to help you. But did you try recording with Anki vs recording with a different app to see if static is present on other recording software (if so that would indicate hardware problem). If static is only reproducible on Anki, then that could indicate a software problem.

1 Like

Have you tried with an external microphone?

Thanks, I hadn’t thought of that - trying recording with another program. I just was baffled as it recorded loudly and clearly multiple times and in the same session of recording not long after those clear recordings it started to record with a static background. I couldn’t work out what changed. I tried again today, still a faint static, I can’t record as loudly* though. Lower volume = lower static.

As per your suggestion, I tested recording using a different app, the existing sound recorder (Voice Recorder App) on my laptop, there is no static in the background when I record through it, using the laptop microphone - it records clearly. I also tested through PowerPoint and noticed a faint static, this program doesn’t allow the sound to be very loud, which makes the static not so noticeable, but it’s still there.

*Anki appears to have the volume of recording adjusted recently, as I can’t record as loudly as the last clear recordings (I tried, with my volume maxed and there’s an obvious difference in volume between new recordings and past). This does present a solution to the problem, lower volume = lower static. However this means that my previous beautifully clear recordings are much louder then today’s new recordings and inconsistent volume creates a “shouting” effect between cards.

I just checked an older deck I created with sound recordings, to see if I could hear static, I had created it on a different laptop and with an older version of Anki. And I was surprised to hear a faint static, which I hadn’t noticed before. This hadn’t affected the usefulness of the deck. I’d guess that the static was always there, but just as in the PowerPoint program it wasn’t noticeable because the volume was set low. This does show that a little static, faint, doesn’t matter for personal use. Not worth investigating. And like you said previously, perhaps this too was a hardware issue. It is hard to determine now.

Despite all this, I can’t understand how I got the loud and clear recordings, using the laptop mic in the latest Anki version. And I wish I could recreate them. So, perhaps it’s a hardware problem yet I recorded clearly using the laptop mic in the Voice recorder app on my laptop or perhaps it’s another issue. Nonetheless, it probably is not worth anymore time, for something that is to be just for personal use and free.

Thanks again for your reply. It gave me another thing to try. I’m not a computer person. I just notice details, a ‘detail’ person. I will make the most of the new deck I created as is; big picture - the cards do work. AND lower volume = faint static, is a solution. And I think the Anki program is a fantastic program.

Two things to bear in mind:

  • if the laptop’s fan is running, that’s going to make the recording noisier
  • the closer you get to the microphone, or louder you speak, the louder your voice will come across compared to the background hiss
1 Like

Thanks for the suggestion BlackBeans. I was hoping not to have to get an external microphone. I will look into this though.

I tested recording my voice through a sound recorder (Voice Recorder App) that was already installed on the laptop and with using the laptop mic and there was no static. The laptop has an AI noise-cancelling mic, would you recommend any external microphone or is there something I should look out for when purchasing one.

Thanks Dae.

I tried recording when there was no audible hum from the laptop. It made no difference. Also, I tried altering my position, closer to the mic so as to come through louder. My latest recordings are better, less static, but too quiet. (Anki appears to have adjusted the set recording volume. Lower volume = lower static. I can’t record as loudly as before. It is now too soft and when playing new cards on my phone they are too quiet and I have to move the phone to my ear to hear well and can no longer see the card while the recording is playing because of this.)

Interestingly, yesterday, I tested recording my voice through a sound recorder (Voice Recorder App) that was already installed on the laptop and with using the laptop mic and there was no static. Thinking of perhaps recoding through that app, but that will be labourious, but its currently the only way I know to be sure of a loud and clear recording. Or thinking of using blue tooth from my phone to external speaker to play cards, but that just makes a simple process more complicated. It looks like I’m going to need to re-record yesterdays new ‘quiet’ cards again. Either way, there doesn’t seem to be an easy fix.

I am considering buying an external mic, but not sure if this will help at all, especially now I am having an issue with the volume being too quiet.

New cards are now too quiet when played on my phone.

If the sound quality is different when recording in Anki and a different app, that seems to imply the problem is not with your microphone, but with the audio tools that Anki is built on. As a workaround, maybe you could record the audio on the Anki app on your phone instead?

Thanks for the suggestion Dae.

I didn’t realise I could record and edit cards through Ankidroid. I tested your idea and it recorded louder this way. Much easier option then my other ideas.