Specific deck not autoplaying audio in only one profile

Autoplay audio is not working for a specific deck in my main profile, which syncs to my iPhone (also not autoplaying there). I have to press “r” to hear the audio which should automatically play when I press “show answer”. All the other decks in that profile are autoplaying audio properly. The weird thing is that this issue is only in my main profile. The same deck works properly in the other profiles when I test it there. I tried deleting the deck, clearing unused media, deleting the note types, syncing, and then downloading it again to no avail. Anyone know why could be happening or how I could fix it?

I am using a Mac with the latest version of Monterey and the latest version of Anki.
My iPhone is on the latest version of iOS and both devices are unmuted at time of testing.

Thank you in advance for your help.

Did you make sure the “Don’t play audio automatically” option in the deck options screen is deactivated?


Wow thank you, I didn’t even think of that. I have no idea how it got switched on. Now all of a sudden I got the following error each time I open/close Anki:
“Please use the Check Database function, then sync again. If problems persist, please force a full sync in the preferences screen.”
After check database didn’t work, I ended up having to do the full sync and that seems to have resolved the issue.
Do you know why that happened?

Also, when I clicked the Check Database button, but nothing happened. Is that normal?

Thank you in advance for your help.

Not sure why this happened. But Check Database should show a dialog like this:

1 Like

I see. When I click check database, nothing happens. It’s always been like that since downloading Anki on my new Mac.

Depending on collection size and computer speed, it may finish before a progress window pops up, but you should still see a yellow popup.

1 Like

I tried it again and got a progress window this time. I added a couple large decks since last time, so that might be the reason why.