Shortcut to create cloze isn't working properly

when i press shift cmd c to create a cloze deletion as i used to do in previous version it automatically creates two cloze like this,
is there a solution for that

1 Like

Perhaps you double-tapping the c? If I press cmd+shift and then press and release c, it doesn’t add a cloze until I release the key.

1 Like

i only tap it once and it always creates two clozes, i’m on anki for mac

Can you provide more details? I’m on macOS 12.3.1, Anki 2.1.53 Qt6 (M1) and I do not notice the behaviour you’re describing, i.e. ⇧⌘C only inserts a single cloze as expected.

However, I can simulate it by creating a cloze using ⇧⌘C then highlighting the cloze that I just made and re-clozing it with ⇧⌘C, if I haven’t release the ⇧⌘ combination before re-tapping the C. It’s not hard to make that mistake if my thumb is resting too heavily on the trackpad.

i’m on the same version of anki on M1, and i’m on tapping on c once like i used to do on older version of anki

What language is your keyboard input set to?

canadien french

image

I tried with that keyboard layout, and still only get one cloze. It’s a mystery.

1 Like

image

The problem is with the keyboard shortcut. As you can see in the above image showing tooltip, the shortcut’s function is to add a new card also - (new card) Cmd+Shift+C

I’m using Mac OS 10.13.6
Anki Version ⁨2.1.54 (b6a7760c)⁩
PyQt 5.14.1

More details
image
When enclosing a text for Cloze using the keyboard shortcut, another card is added next to the cloze also, as shown here. This happens without double-tapping the c. I thought this is a new feature initially though apparently it is not.

Screenshot from Anki version Version ⁨2.1.49 (dc80804a)⁩ PyQt 5.14.2
image
The tooltip of the older version does not include new card

1 Like

(post deleted by author)

I found the solution, I was having the same problem, using the same version of anki as you. I went through disabling my add-ons looking for a culprit & I found it.
Try disabling this add-on:
24411424

1 Like

This problem is solved in the latest beta version though. I’m glad it is solved.
Anki 2.1.55 Beta

2 Likes

ashyaura
I have discovered something that I would like to leave it here. It may become useful if someone comes across this in future

You are right - the culprit is the add-on “Customize Keyboard Shortcuts”. But there is a solution in the same add-on.
Alternate keyboard shortcut “Ctrl+0” (Ctrl+Zero) is given by default to create Cloze cards.
This shortcut does not create duplicate clozes in Anki Version ⁨2.1.54 (b6a7760c)⁩ PyQt 5.14.1.

So one need not disable the add-on. Also 2-key combination of the shortcut makes it easier (personal opinion) to work with.