Shift doesn't work... what are my options?

My Anki was working fine just a week ago, then suddenly I could no longer open it on Desktop. I’ve heard that this is usually because of an Add-ons, and to hold shift down while running it to tell Anki to start without any Add-ons. However, I’ve tried holding shift down but Anki still refuses to start. The exact behaviour is that it the Anki icon is created in my tray for about 1 second, nothing happens, and then the icon disappears. The same thing happens when I hold shift down.

I’ve double-checked that I’m using the latest version (2.1.54).

I use Linux kubuntu, and when attempting to run Anki from the command line, it outputs:

Traceback (most recent call last):
  File "/home/eliclax/.local/bin/anki", line 5, in <module>
    from aqt import run
  File "/home/eliclax/.local/lib/python3.8/site-packages/aqt/", line 15, in <module>
    import anki.lang
  File "/home/eliclax/.local/lib/python3.8/site-packages/anki/", line 12, in <module>
    import anki._backend
  File "/home/eliclax/.local/lib/python3.8/site-packages/anki/_backend/", line 15, in <module>
    from anki import backend_pb2, i18n_pb2
  File "/home/eliclax/.local/lib/python3.8/site-packages/anki/", line 33, in <module>
  File "/home/eliclax/.local/lib/python3.8/site-packages/google/protobuf/", line 755, in __new__
TypeError: Descriptors cannot not be created directly.
If this call came from a file, your generated code is out of date and must be regenerated with protoc >= 3.19.0.
If you cannot immediately regenerate your protos, some other possible workarounds are:
 1. Downgrade the protobuf package to 3.20.x or lower.
 2. Set PROTOCOL_BUFFERS_PYTHON_IMPLEMENTATION=python (but this will use pure-Python parsing and will be much slower).

More information:

Although it should be noted that this may be caused by trying to run an old version: running apt info anki outputs:

Package: anki
Version: 2.1.15+dfsg-1
Priority: optional
Section: universe/misc
Origin: Ubuntu
Maintainer: Ubuntu Developers <>
Original-Maintainer: Andreas Bombe <>
Installed-Size: 4,586 kB
Depends: python3:any (>= 3.6~), python3-pyqt5 (>> 5.11), python3-pyqt5.qtwebengine (>> 5.11), python3-pyqt5.qtwebchannel (>> 5.11), libqt5core5a (>= 5.11), python3-distutils, python3-bs4, python3-pyaudio, python3-requests, python3-send2trash, python3-decorator, python3-markdown, python3-jsonschema, python3-distro, libjs-jquery, libjs-jquery-ui, libjs-jquery-flot, libjs-mathjax
Recommends: python3-matplotlib
Suggests: dvipng, mpv | mplayer, lame
Download-Size: 806 kB
APT-Sources: focal/universe amd64 Packages

(I removed the Description from the codeblock)

What are my options? Are there any ways to manually prevent Add-ons from running?

Thanks in advance!

Thanks for the response! Unfortunately, I have downloaded Anki via the website, not through my distro, so that page doesn’t really apply to me. Does anyone know a method to disable Add-ons other than by holding the Shift key?

You can enable/disable add-ons via Tools > Add-ons

The error message you provided indicates you’re not using the bundled build available on the Anki website, as it’s using your system Python install.

Uhhhh I’m not sure what happened exactly but I managed to fix it. I tried downloading Anki again, and realised that running the anki.desktop didn’t work, but running <PATH TO DOWNLOAD>/anki from command line did work. It seems like the anki.desktop file was running anki %f from the command line. I changed it to run <PATH TO ANKI>/anki from command line, and everything seems to be working now :slight_smile: