Shift-click to select multiple cards in card browser broken

Steps to reproduce:

  1. Open card browser and make sure you have at least 2-3 cards
  2. Click on first card to select it
  3. Shift-click on any other card

Expected behavior:
First card click, last card clicked and all cards in between are added to the current selection.

Actual behavior:
Only the last card is selected.


  • Anki 2.1.41
  • MacOS Big Sur 11.2.2

I can reproduce this every time. I’ve tried all the troubleshooting steps described in (restarting Anki, checking plugins, etc).

I’m pretty sure this worked in the past because I used it all the time, but I don’t know exactly when did it stop working.


Works for me on Windows.

Same here, works with Mac and 2.1.40, will test out 2.1.41 later today. It might be that sometimes the first selection is ignored so there’s a need to always do an initial and final selection, but it’s just a guess just now.

After reading Kent’s comment I went back to Anki try double-clicking at the beginning and end of a multi-card selection and some times that seems to work but the behavior doesn’t look deterministic or repeatable to me.

See this video, it shows a mix of normal and shift-clicks and single and double clicks attempting to create multi-card selections.

I was able to reproduce it after trying more. It happens in your video more frequently.
Seems random to me.

@Rumo perhaps we have a race condition? I can’t seem to trigger it here

I can reliably reproduce the issue when I run the binaries (tested as far back as 2.1.22) but not when I run from source, not sure what that tells us. :thinking:
Also as far as I know, Anki doesn’t really interfere with the table selection, it’s handled by a default selection model. So I hate to say it, but maybe it’s a framework issue?

Thanks, it may be a Qt 5.14 issue. I can’t seem to trigger it if I make sure to shift+click when the mouse is completely still - it only seems to happen if there’s a slight movement at the time of the shift+click.

@dae I’ve spent 1min trying shift-clicking with mouse completely still but I couldn’t get it to work. Then I re-did my selection from scratch and it worked the first time, so it does look like a race condition issue.

Update: I think dae is right. When I switch from my bluetooth keyboard + Logitech MX Master laser (sensitive) mouse to the Macbook Pro’s trackpad, I can reliably get shift-click selections working and I can’t reliably trigger the bug (but it’s still possible if I try to slide my finger on the trackpad while end-clicking).

It would be great if it were still possible to fix the issue because I normally work with the laptop closed on a vertical stand and I don’t have access to the trackpad.

Thanks everyone

While it seems Qt 5.15 fixes this, it unfortunately introduces a number of other regressions, so we’re stuck for now.

The problem persists on:

Anki 2.1.49
macOS 12.0.1
MacBook Pro M1 Pro
No browser add-ons enabled

1 Like

2.1.49 still uses the same toolkit version. You may have more luck with the Qt6 beta.

I can confirm for my part that I did have this trouble with 2.1.49, but the 2.1.50b2 beta with QT6 seems to have resolved it for me.

I am on Monterey 12.1 using a 1st-generation Apple Magic Trackpad (external).

1 Like