Anki crashing when I try to select multiple cards in browse section

I recently updated to anki 2.1.60 Qt6, Apple Silicon for my M1 chip macbook. Everytime I go to the browse section and select/highlight multiple cards via click and drag, anki crashes. I have tried to restart my laptop, deleting/redownloading anki, and deleting all add-ons, but it continues to crash. However, anki still works fine on my desktop

It’s unfortunately likely to a bug in the graphics toolkit Anki is built on. Possible workarounds you could try: shift+clicking instead of dragging to select, or switching to the qt5 build.

Anki keeps crashing as soon as I try selecting multiple cards form the Browse tab. Command A and dragging with mouse causes it to crash. Problem has persisted for 2 days.
Things I have already tried:

  1. opening anki with pressing shift button do disable add ons (problem persists)
  2. downloading different version (I already downloaded latest version when it came out, I have mac M2 computer and downloaded apple silicon and tried it with intel version)
  3. restarting computer
  4. upgrading software to ventura on computer
1 Like

Seems related to

I have the same problem and it started today. I keep getting this message.

1 Like

Other things you could try:

  • changing the layout in the View>Layout setting
  • renaming your prefs21.db file to something else while Anki is closed, to reset all window locations/sizes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.