Anki Forums

Macbook Air M1 Chip Shit+Click on Brower Not Working - External Mouse

Hello,

I recently bought an M1 Macbook and have been having a problem with Shift+click on multiple cards. When I try to select cards through this method, it just skips all the cards and goes to the last one I selected.

Cmd+click works perfectly fine.

Some insight would be really helpful.

P.S. I for got to mention this only happens with external mice. I have tried multiple mice and ended up with the same results.

I’ve seen this too. Just now I tried to find a reproducing rule, but couldn’t. However, I did see this with high, but not 100%, frequency— assume cards are contiguous in list:

click on 1st card; it selects;
Shift-click on 2nd card; it selects, 1st card unselects;
Shift-click on 3rd card; all three cards select.

Mac Mini (2018); MacOS 11.3

I believe it’s caused by your mouse cursor moving slightly as you perform the click - if the mouse is kept still, it should select properly. It’s an issue in the version of the toolkit Anki uses.

Even with the cursor moving, the track-pad Shift+click works perfectly, its an issue when using an external mouse

I experimented with this and I think it is not the cause.

At first, paying attention to keeping my external mouse still while clicking, I couldn’t reproduce the failure. Then, with no change in technique, the failure became frequent. To check, I used Mouse Coordinates.app* to display mouse coordinates, and confirmed that the problem occurs with no mouse movement.

Also, I was able to reproduce the problem on a 16" MacBook Pro with no external mouse attached.


*I am going to start an Anki GoFundMe for reimbursement of the U.S. $0.99 this app cost.

I way to rule out movement without an external app would be to lift the mouse off your desk, and click it while in that state. Thanks for the update in any case, though I still think this is a toolkit bug unfortunately.

Hi dae,

You were absolutely correct, it was the slight movement of the mouse. Lifting the mouse in the air works perfectly when doing Shift+click, it is not ideal though.

I can reproduce the double-click “contracting highlight” with the mouse off the desk.

Sounds like they’re two separate issues