Setting fade to 0 still fades card in when opening card from deck browser, and other UI transition behaviours inconsistent

On AnkiMobile, despite

  qFade = 0;
  if (typeof anki !== "undefined") anki.qFade = qFade;

(source) being added to the front of a card template to prevent them fading in, a fade-in effect will still be played when pressing on a deck when the first card is opened from the deck list. When moving card-to-card the fade-in effect is not shown (as expected).

Similarly (or perhaps not), when set to dark mode, a white screen is briefly shown in the space where the “Congratulations! You have finished this deck for now. If you wish to study…” notice is shown when clicking on a empty deck.

The two above behaviours may be a result of waiting to load the cards until after the transition to a deck has completed. You can see another instance where these transitions happen with the wait (Deck List to Stats) and one where the next screen is already loaded when displaying the animation (Deck List to Settings).

A quick fix of overlaying or changing the colour of the place-holder box of the “Congratulations…” screen to the background colour of dark-mode Anki would fix the 2nd issue, but a more thorough approach would be needed to fix the rest.

IIRC the initial fade in is to allow the page to finish loading first, to avoid flicker as the webview loads. I’ve added a note to look into the flash on the congrats screen in might mode.

I have noticed seen that the flash also happens on Anki Desktop 2.1.55 beta 6 (ca116699) and Anki Desktop 2.1.54 (b6a7760c)⁩, though the colour is not as obvious (it is too fast for me to tell if it is white or black or transparent)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.