Anki Forums

Saved searches not getting saved in Anki 2.1.43

Hello there, i noticed that saved searches updates sometimes don’t get saved! I noticed this because yesterday i update all of my searches and today i found them as they were before … I’m using Anki 2.1.43.
Could it be that ankidroid overwrited these searches (as i reviewed some cards on my phone)? Or it may be some addon conflict?
I’m using these addons

Or is it a problem with the new anki update? I’ll let you know if this happens again! Thank you !

1 Like

One user reported it to have been caused by an add-on:

Even if you don’t use that specific add-on, I would try to the usual strategy of gradually enabling/disabling your (many :wink:) add-ons.

2 Likes

Thank you; i don’t have customize sidebar installed, and i don’t have addons that change the browser either, beside fastbar that is only graphical as far as i know, and browser resizer that should be graphical only too… Since i have no idea about what triggers the loss of saved searches, activating and deactivating every other addon randomly would be a nightmare since i wouldn’t know if the error didn’t appeared because of the addon i deactivated or because i didn’t triggered the event that used to cause the error.

Another hypotesis would be that it’s triggered by the syncing between ankiweb and ankidroid, is it possible?

Of course, the first step would be to see if you can reproduce the issue at all by just saving a search and restarting. Did you do that? If it happens reliably, you can then start Anki without add-ons (holding down Shift) and see if the issue is still reproducable.
Neither Damien nor a contributor can do much about a bug if add-ons haven’t been ruled out.

I guess it’s possible but it seems unlikely to me. I personally use Ankidroid and don’t have any problem with saved searches.
Syncing as well can be ruled out easily if you can otherwise reproduce the bug reliably, by the way.

2 Likes

I have the same issue. I don’t use mentioned add-on. Restart/sync doesn’t cause the saved search to disappear but yet after some time (the next day? not really sure, ma be more) it’s gone. I tried doing dozens of restarts/syncs and it’s still there. Running anki without addons for the couple of days could be somewhat annoying just to rule them out.

Here are the addons I use.

I still get this error every now and then; it doesn’t seems related to anything in particular. I just make backup of the saved searches to restore them if they disappear.
Anyway, i only have these addons in common with you:

  • highlight search result in the browser
  • load balanced scheduler
  • mini format pack
  • more overview stats

So the culprit is one of these, or it is an anki bug

The weirdest thing is that it seems quite random. It’s not the restart nor the sync… just one day they are gone.

Any chance to see this solved this the latest updates?

Since it’s not something the developers are experiencing, no progress is going to be made on this until you do some experimentation and narrow down the steps/client/add-on that is causing it. You both use AnkiDroid and AnkiDroid has code dealing with the saved filters. If you are using them or modifying them in AnkiDroid, that would be a good first thing to experiment with after you’ve ruled out add-ons.

These are the addons that me and wojtek have in common

  • highlight search result in the browser
  • load balanced scheduler
  • mini format pack
  • more overview stats

I haven’t done anything strange, the only culprit that comes to my mind is that i’m occasionaly using ankidroid on a very old tablet that sometimes give me strange errors. Since when i stopped using that tablet the error stopped too, but rarely it randomly occurs again

Interestingly enough, I haven’t seen that issue since my last message (though, I didn’t need to use that query all that much in those days)