Anki Forums

Right hand reviews / hjkl answer shortcuts / Handy Answer Keys (configurable) [Official thread]

If you have a problem with the add-on right hand reviews / hjkl answer shortcuts / Handy Answer Keys (configurable) post in this thread. This way I get notified. If you make a new thread I will likely miss it. If you post your comment, question or bug report on ankiweb as a review I won’t get notified. You really should post in this thread.

Hi, first of all thank you for writing this great add-on!

I I’m using filtered decks for cramming and there are only 2 answer buttons (again and good). I want to be hit ‘k’ for the ‘good option’ and ‘j’ for the ‘again’ option. I’ve been able to set up the ‘k’ for the ‘good button’ (with “adjust_the_meaning_of_the_answer_keys_depending_on_number_of_answer_buttons”: true) but I can’t seem to be able to set up the ‘j’ button. I’ve tried setting “adjusted_answer_keys__second_key_for_less_than_four_buttons” to both ‘defaultease’ and ‘fail’ but with each setting ‘j’ also hits the ‘good’ button. Basically I want ‘j’ to hit the first button out of the two available. Can you please help me with this? Many thanks! :slight_smile:

the left button always means fail and for fail you use the button “reviewer_1”. So I don’t think it’s enough to adjust the config but you need to change the source code.

Maybe add two lines behind this line so that it looks like this:

        if ease == 1:     # 1 is always the leftmost button
            self._answerCard(1)
        if ease == 2 and cnt == 2:
            self._answerCard(1)
        elif ease == 4:   # 4 always the rightmost button/highest ease
            self._answerCard(cnt)

That’s untested. Use it at your own risk. At the moment I don’t use the add-on.

1 Like

Wow, it works, thank you so much!!! :grinning:

In the meantime I’ve also worked out another technique to keep keystrokes consistent across decks with 2 and 4 buttons. I thought I’d share this here in case somebody else is interested:

  • use the ‘customize keyboard shortcuts’ add-on
  • set up custom shortcuts:
    “reviewer choice 1”: “j”,
    “reviewer choice 2”: “k”,
    “reviewer choice 3”: “”,
    “reviewer choice 4”: “l”,
  • when studying, use space bar to mark card as ‘good’, use ‘j’ for ‘again’, and ‘k’ and ‘l’ for hard and easy
  • this works for cards with 2 or 4 buttons

Stopped working on 2.1.30 after I installed God mode add on.

https://ankiweb.net/shared/info/1508677152

image

@mfraidmylord: You have to decide which add-on you prefer. There’s nothing I can do.

Both add-ons modify the same parts of the reviewer, i.e. the functions _shortcutKeys and _answerCard.

My add-on makes the change in a way so that in general it should work with other add-ons. From a technical point of view I wrap a built-in function, i.e. I tell Anki that instead of just executing a built-in function it should execute some of my code and then the built-in function.

Godmode tells Anki to totally ignore the built-in function and instead use a custom one. So a true fix needs to be made by the godmode add-on. Though sometimes just wrapping is not enough and two add-ons are truely incompatible. It’s a bit unexpected to have code that modifies the reviewer in an add-on that’s mainly about easier cloze shortcuts in the editor.

Edit: I just looked at the source code of the godmode add-on and it has this remark: “I attempted to make GODMODE with its own limited shortcuts, but found that it interfered the above addon. So the easiest solution for me was to merge the two addons into one so that they don’t conflict.”

Add-ons are usually shared for free and so these are mainly tailored to the add-on creator and everything that makes life easier for an add-on creator is a good reason in my view even though sometimes it has side-effects for other potential users …

Edit2: Also see the issue I opened in the godmode repo

1 Like

Thank you!

Hello,
Thank you for creating this add-on. I am not great with anki add-ons and programming in general. I have been using anki for over a year and recently got a typical presentation clicker that I am trying to program. I simply want to change “1” to “escape” , “2” to “page up” , “3” to “shift+5”, and “4” to “page down”. I have been having trouble adding this. If it sounds like I need it spelled out rather simply or help with what to directly copy and paste into the configure window for this add on, it is because I probably do…

Any advise is helpful! thank you!

@alexotto002: Maybe try this config:

{
    "rate_from_question":false,
    "reviewer_1":"Qt.Key_Escape",
    "reviewer_2":"Qt.Key_PageUp",
    "reviewer_3":"Shift+5",
    "reviewer_4":"Qt.Key_PageDown",
    "adjust_the_meaning_of_the_answer_keys_depending_on_number_of_answer_buttons":false,
    "adjusted_answer_keys__second_key_for_less_than_four_buttons":"ignore"
}

if this doesn’t work there’s also the add-on Customize Keyboard Shortcuts.

Hey I am on the latest Mac OS Big Sur and the latest anki , for some reason my reviewer 1 and 2 command for h and j are not working. But the reviewer 2 and 3 are working. If this could be fixed that will be great. These are my configuration settings.

{
“adjust_the_meaning_of_the_answer_keys_depending_on_number_of_answer_buttons”: false,
“adjusted_answer_keys__second_key_for_less_than_four_buttons”: “ignore”,
“rate_from_question”: false,
“reviewer_1”: “h”,
“reviewer_2”: “j”,
“reviewer_3”: “k”,
“reviewer_4”: “l”
}

@arsh.appleid: I need more info:

  • Just to confirm: You are on Anki 2.1.35?
  • Did it work originally? If so: What changed since it last worked?
  • To narrow down the problem: Disable all other add-ons, restart Anki and try again. Does it work? If it does it’s an add-on conflict. Reenable half of your add-ons, restart and try again. If it still works reenable half of the remaining, restart, and try again and so on. Until you find the conflict. Then check the add-on configs if you can reconfigure the other add-on. if not you must decide which add-on to use.

I just tried on my computer and “h” and “j” work for me.

In general the most common source of problems is add-ons in Anki.

When it comes to shortcuts not working the most common source are conflicts: If Anki or another add-on has the same shortcut as my add-on these shortcuts don’t work. e.g. “h” is used by the add-on “Tag Toggler”, “Add tags by shortcuts in the Reviewer window”. “j” is also an easy to type = popular key for add-ons.

1 Like

Thanks you were right it was some other add-on , sorry for bugging you.