[reopening] “Ignore reviews before”-setting lost during syncing

I use the “Ignore reviews before”-setting to have FSRS ignore the older part of my review history. What I have noticed a bug, that under some circumstances, this setting doesn’t get synced or gets reset.

I have posted this before and an ankiweb dev has said that:

Sadly, the issue remains to this day and the previous topic has been automatically closed without the possibility of reopening it. This is why I write a new post to bring this issue to attention.

Conditions

  1. During a full sync, no matter what is pushed to ankiweb, the date will reset to 1970/1/1.
  2. Sometimes, a value will just outright not appear on AnkiDroid (though I don’t know where it happens). Might also be a bug with AnkiDroid, but I currently cannot check. (this seems to be fixed now, or at least didn’t happen again)

Reproducing the bug

  1. Change the “Ignore reviews before” value in the settings of a group.
  2. Sync with ankiweb
  3. Force oneway sync from ankiweb, replacing the local state.
  4. Setting has reset to 1970/1/1.

Anki Version

Version ⁨24.04.1 (ccd9ca1a)⁩
Python 3.9.18 Qt 6.6.2 PyQt 6.6.1

PC

Field Value
OS Microsoft Windows 11 Pro
Version 10.0.22631 build 22631
Model Surface Pro 9
System Type x64-based PC
Processor 12th Gen Intel(R) Core™ i7-1255U、2600 Mhz、10 cores、12 logical processors

You use the word “sometimes” so does it mean the reproduction steps don’t always work?

Sorry for the misunderstanding, the sometimes referred to the second condition, which I couldn’t really reproduce.

I haven’t found time to push the changes to AnkiWeb yet I’m afraid (they’re currently blocked by some unrelated breakage). It’s still on my radar.

3 Likes

I completely understand! I just saw that the last topic is closed and cannot be posted on anymore, so I wanted to “reopen” it, as it is still an issue.

1 Like