Rating buttons not appearing on 2.1.57

Hi there,

Since upgrading to Anki 2.1.57, I find that neither the “Show Answer” button, any of the rating buttons or the cards remaining row are appearing in the UI. I can still press the space bar to navigate through the cards, however the buttons never appear.

Anki does not crash and I am not presented with an error. When first opening the deck there is a very brief visual glitch where the buttons should be. I would suspect this is related in some way?

I’m happy to submit any debug logs, though after some brief googling I couldn’t find how I would do this. When I downgrade to 2.1.56 the issue no longer occurs.

Here’s debug info from the app:

    Anki 2.1.57 (6b7d372c) Python 3.9.15 Qt 6.3.2 PyQt 6.3.1
    Platform: macOS-12.6.2-x86_64-i386-64bit
    Flags: frz=True ao=False sv=2
    Add-ons, last update check: 2023-02-05 21:23:42
    ===Add-ons (active)===
    (add-on provided name [Add-on folder, installed at, version, is config changed])
    ===IDs of active AnkiWeb add-ons===
    ===Add-ons (inactive)===
    (add-on provided name [Add-on folder, installed at, version, is config changed])

Separately, just to say thank you so much for all the effort you put into Anki. It’s truely an incredible app.



That’s a weird one - do you have the user interface size in the preference set to something other than 100%?

(and presumably you don’t have ‘hide bottom bar during review’ enabled?)

My appearence settings seem to be at their default values.

I managed to get the buttons to appear again by switching the user interface size to 150%. What’s strange though is that I’ve now set this setting back to 100% and the issue has gone away!

Seems like it could be a hard one to reproduce.

Glad to hear the issue has resolved itself; I’ll keep an eye out for similar reports.

Have the same issue with a user interface size of 200%. The bottom bar disappears when the window is relatively small, but shows up if the reviewer is opened when the window is larger.

I experimented a bit and it seems that the bottom bar works without issues if the “reduce motion” option is enabled.

@kleinerpirat heads up

Persists in 2.1.60.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.