Order of new cards by ranking field

Hi,

my notes have a field “Rank” to indicate the order I want to learn “new cards”.
How to do that?
At moment new cards can be sorted by “due” only.

Best regards

You can separate the cards into different subdecks, or reposition them

https://docs.ankiweb.net/deck-options.html#new-card-gather-priority
https://docs.ankiweb.net/browsing.html?#cards

@cqg
Thanks for answering.
I am not english. Maybe I donnot understand everything correctly.

I have imported

https://ankiweb.net/shared/info/107258650

via apk.

There are no subdecks.

In Tools → Preferences → Scheduling I have marked “V3 Scheduler”.
In Options → New cards → Insertion order → Sequential

To my knowledge, here is my problem:
In Options → New Cards → Display order → New card sort order → Card template, then ascending (default)

In advanced browser there is a column “due” with values like “New #1” etc., which are correct.

In advanced browser → Fields → Rank → Options I have marked “Sort by this field in the browser”.

Problem:
In learning mode → study now

cards with very high Ranks like New #3513 are shown instead of New #1, New #2

OK, in that particular case, using subdecks is not appropiate. Open the deck, then

  • Browser > Fields > Rank > Sort by this field in the browser
  • Browser > Click on “Sort field” column. Now all cards are ordered by “Rank” field
  • Select all cards > Right button > Reposition. Now the due value correspond to the “Rank” field.
  • Start studying using your deck options. It should work now.
1 Like

Browser > Fields > Rank > Sort by this field in the browser

=okay

Browser > Click on “Sort field” column. Now all cards are ordered by “Rank” field
=okay. So far I had it done before

Select all cards > Right button > Reposition. Now the due value correspond to the “Rank” field.
=I have done this, although “Due” value and “Rank” had corresponded correctly before.

There are (and were) correct values in the “Due” column like “New #1” ,“New #2”, “New #3” etc.

Start studying using your deck options. It should work now.

No, it is not. I get randomnly ordered new cards.

Probably the solution is very simple, but I am afraid I do not understand (due to translation) the usage of

Options → New Cards
or
Options → Display Order.

Please recommend what I should choose here for my simple case.

Working properly here.

Are you 100% sure? This is what I got just after importing the shared deck:

And this is what I got after reposition cards:

Could be this the problem?

If not, you can try try to deactivate all addons you may have and use default deck options. That should definitely work.

Yes, this seems to be the problem:
I do not get something like “New#677”.

The column “Due” is empty after fresh installation and remains empty after “Reposition”, even with all addons deactivated.

Solution:
I could solve the problem by using another profile.

Thank you very much for your assistence.

You probably had the notes/cards selector at the top set to notes.

@ dae
Could be. Thank you very much for your advice!

Have a good day.