No Japanese input available on latest beta, Linux

I have tried mozc, anthy, and kkc across both Ibus and fcitx. I am able to type Japanese into other programs, but only Anki isn’t accepting it, and simply displays romaji as if I wasn’t using an IME. I can copy and paste Japanese text into Anki, as well as use premade decks with Japanese.

I’ve also looked at other posts on this site and others, but none of them have been able to solve this problem.

Maybe you haven’t set the env vars correctly?

Sorry for the late reply.
Unfortunately, I’ve already set those up, and even when changing them it didn’t seem to affect anything.

Could you provide some information about your system? Which distribution, which DE (if any) or WM, Wayland or X11, and how did you setup Japanese input on your system?

Also, can you reproduce this issue with older version of Anki? With other software that use the same Qt version as the version of Anki you have?

1 Like

Could you please confirm if Japanese input worked in 2.1.51, and 2.1.52? If it’s due to the Qt upgrade, I’d expect 2.1.51 to work, and 2.1.52 to not. If 2.1.51 doesn’t work either, that seems to imply the issue lies elsewhere, and I’d double-check that other Qt apps are allowing Japanese input.

I can confirm that it was working before the upgrade. I am having the same problem, I used to input Japanese with Mozc no problem (and it still works for every other application) but can’t in Anki. It is definitely because of the UI/Qt change.

Just to make sure we’re on the same page:

  • this is with the binary from the Anki website?
  • if you download the 2.1.51 binary, Japanese input starts working again?

Oh sorry for the late reply I did not see an email notification for some reason. I was using the anki package from the AUR. I just tested the 2.1.51, 2.1.52, and 2.1.53 qt6 downloads directly from the git releases page and they actually work fine so it seems to be an issue with either the AUR script or maybe a library on my machine.

The only major difference I can see is that my own build is using Python 3.10.4 while the official build is on Python 3.9.10, so maybe it’s that? But obviously this is a problem on my end and not with Anki itself so I don’t want to waste your time.

EDIT: In case anyone comes across this in the future I was able to get it working by installing the fcitx-qt6 package.

1 Like