[2.1.55] Can't type japanese text after update (fcitx+linux issue)

Starting with 2.1.55-qt6 I’m now unable to switch to the japanese IME for my keyboard when in the card browser. Usually pressing Win+Space or clicking on the keyboard switcher on the taskbar can toggle Mozc IME on and off but in the new version it just doesn’t do anything. On 2.1.54-qt6 it works as you’d expect. My keyboard driver is fcitx rather then ibus

Edit: If im in the card browser on 2.1.55 and hover over the keyboard indicator it says “No input window” where before on 2.1.54 it says “English” or “Mozc” so probably an issue with it not being able to detect the text boxes

System Info
OS: KDE Neon 5.26 (Ubuntu 22.04)
Desktop: KDE Plasma 5.26.4 (X11)
Keyboard: Fcitx + Fcitx-Mozc 2.26.4220.100

Thanks for the report, I’ve logged this on fcitx input broken on Linux? · Issue #2278 · ankitects/anki · GitHub

Just to confirm the above - I have the same issue with 2.1.55 Qt6 on Ubuntu 22.04. After downgrading to 2.1.54 Qt6, the fcitx Mozc input works fine again.

Please let us know if it’s not resolved in the next beta.

I believe it’s still not working for me, on Ubuntu 20.04. The important thing to note is that I’m still using fcitx4, whereas the linked issue only says it was fixed for fcitx5. Perhaps it’s a similar issue?

I’m using the latest beta release to test:

Version <U+2068>2.1.55 (e0c4ba4b)<U+2069>
Python 3.9.15 Qt 6.4.0 PyQt 6.4.0

2.1.55 is not on beta anymore, try the latest version to see if the issue got resolved
Release 2.1.55 · ankitects/anki · GitHub

Version <U+2068>2.1.55 (01caec2a)<U+2069>
Python 3.9.15 Qt 6.3.2 PyQt 6.3.1 -> Mac version

Ahh my apologies, I thought the latest in the beta releases was more recent.
Nonetheless, it still doesn’t seem to work for me on the latest version.

Here is the version I’m using now:

Version <U+2068>2.1.55 (01caec2a)<U+2069>
Python 3.9.15 Qt 6.4.0 PyQt 6.4.0
1 Like

Isn’t 01caec2a the stable release of 2.1.55? The issue was supposedly fixed in e33bed2 which is a newer commit then that one and it doesn’t seem like a beta has been released for that yet


Sounds right to me, guess we’ll just have to wait for the next beta release. Apologies for the bother!

This issue is fixed for me in the new release candidate. Anki 2.1.56-rc1 qt6 + Fcitx 4


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.