New version crashes every time I search

Since this morning, every time I search for something in a deck using one of the card fields (e.g. “target:test”), Anki immediately crashes. Searching the string by itself without specifying a field name (e.g. “test”) doesn’t produce this problem. It was working fine up until yesterday.

I tried disabling all the add-ons (2 in total), yet it’s still happening. I tried reinstalling, downgrading, rebuilding the database… yet it keeps happening. Anki is practically unusable at the moment.

Any ideas?

I’m using the recent 2.1.61 version Apple Silicone. I have a Macbook M2 pro. Let me know if you want me to post the crash report or anything else…

OK, weird update… I tried to think what had changed between today and yesterday when it was working fine. Well, I’m working from a Starbucks today (and connected to their WiFi). I figured it was a long shot, but I tried disconnecting from their WiFi and connected to my hotspot. Voila, no more crashes. What’s more baffling - now when I connect back to the Starbucks WiFi, it no longer crashes either. What the hell?

If you find it happens again, please try updating to 2.1.62.

It’s happening again… however, this time I think the cause of the crash is more specific: When I search for a string in one deck, that exists in another deck, Anki crashes.

Here’s the play-by-play:

  1. Browse a deck and select it on the sidebar (make sure the Search field selected the deck)
  2. In the currently selected deck, search for a string that exists in another deck selected.
  3. Boom. Anki crashes

This continues happening across many decks, so I believe this is indeed the issue. Searching for strings that appear in the selected deck works fine. The problem only seems to occur when I search for words from another deck

Did you try with 2.1.62?

I have the same issue. I uploaded to 2.1.62 and it is still happening.

When you say “same issue”, is it exactly as the original poster said, or do you just mean you’re getting crashes when searching? I think it’s unlikely that the matches being in a different deck would cause this; it’s more likely some sort of race condition that certain searches trigger. Another thing you can try is ensure the browse screen is closed, then reset the window positions in the preferences window.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.