Anki Forums

New tags not being synch'd

This is both IOS and MacOS.

I do my studying on an iPad, but I do my edits and additions on MacOS.

But because of the method I use to update, sometimes I tag things on IOS for me to look at/work on with the laptop.

These tags are ASK, AUDIO, and EDIT. I’m guessing ASK and AUDIO are in some way reserved? Because when I look for them in the browser on MacOS (after synch), the EDITs are there but the ASK and AUDIO are not. If I go back to the iPad, the Browse there does find them. (IOddly, ONE of many times, an AUDIO tag did show up on the laptop.)

That’s strange. If they’re not there after closing and opening the Browse screen, please use Check Database in the Tools menu and then open the Browse screen again. Does that fix it?

I opened the desktop (which does a sync(, opened the browser, and looked for the AUDIO tag. Not there. Looked for the EDIT tag, it is there.

Opened the IOS app, triggered a sync, went to the deck, typed in “tag:AUDIO” and two notes appeared.

I did Check DB on the desktop and re-opened browse an d the two AUDIO tags are there. I do a check DB almost every time I add things, so this is weird.

Now off to check the other issue.

Please create a sample deck with a few cards that demonstrates the problem, then share it somewhere so we can try to reproduce it.

I’ll try to do that this week. Meanwhile, on Ankiweb now, I have a large deck “Nederlands.” Earlier today, on the iPad, I added the tag “ASK” to five notes, “AUDIO” to one, finished my daily quota, and synchronized.

Just now, I opened Anki on the laptop, then opened the browser. Tags ASK and AUDIO were not available. Without triggering another sync, “check database” made them appear.

Tags are sent from most recently changed device to other devices. If they don’t appear in the sidebar in the browse screen after syncing, that implies you are making some change on the computer version prior to syncing, or something like an add-on is doing so.

I don’t think that’s it. Because they DO appear after I check database (without a re-sync or other change).

  1. Open Anki to do sync and get the following:

    Anki 2.1.33 (3f403040) Python 3.8.0 Qt 5.14.2 PyQt 5.14.2
    Platform: Mac 10.15.6
    Flags: frz=True ao=False sv=1
    Add-ons, last update check: 2020-09-14 22:26:26

    ===Add-ons (active)===
    (add-on provided name [Add-on folder, installed at, version, is config changed])

    ===IDs of active AnkiWeb add-ons===

    ===Add-ons (inactive)===
    (add-on provided name [Add-on folder, installed at, version, is config changed])

  2. Open browser and check tags. ASK and AUDIO are still in the list but find no notes (because I removed them yesterday).

  3. Close browser, check database, open browser. ASK and AUDIO are no longer in the list.

  4. Close Anki and open it on iPad. About says “2.0.67 (20067.1)”. Synchronize gets a time-out. This, I believe, is a problem with the iPad itself. When it happens, the app store also fails but email and websites continue OK. It generally will work again after an hour or two. So I’ll continue the test then.

  5. (After a few hours) Open Anki on iPad, synch, and select deck Nederlands. Verify with Browse that tag ASK is not there.

  6. Exit Browse and Edit first card. (Note 752) Add tag:ASK. Save and exit Deck. Sync and close app.

  7. Open Anki on Macbook. After auto-sync completes, open Browser. There is no tag:ASK.

  8. Check Database and re-open Browser. Tag:ASK is now visible in the list.

Tags are part of the note content, which can be synced in either direction. The list of tags is synced as part of the collection, and only flows from the most recently modified client. A DB check rebuilds the tag list from the note content. So it does sound like something is marking your collection changed on the computer version, or you are not syncing at the start and end of each session (https://youtu.be/YkiM4DPzSVc?t=224)