New card type not syncing to mobile/other users of same profile


I have created a new card type (please see here the card info):

These cards are working on my computer (Anki desktop, Mac) but they are not updating to Anki mobile or for other users of the same profile.

I create these cards for my English students; they work well on my Anki desktop but not at all on my Anki mobile, or on my students’ devices.

On my Anki desktop, the front of these cards looks like a conventional type-in-the-answer, even though I have created them using the Cloze function (so that I can easily create multiple type-in-the-answer cards for one sentence). The back shows the answer and the Audio and Extra Notes, if I add them.

When my students and I view these cards elsewhere than in my Anki desktop where they were originally created, the FRONT of the card is just a blank screen that says “Type in the answer” at the top, and the back of the card shows the sentence with the answer bolded in blue (as usual for the back of a Cloze card) and the audio.

Can anyone help me figure out what is going on and how to fix this?

Thank you very much in advance!


At the front side you need and at lest one field which has no type in it:


Older versions of Anki, prior to a change affecting the type in cards would work whereas most recent versions won’t. I cannot recall in which version that was introduced.

1 Like

Thank you so much for the prompt help and support, Guillem!

However, I’m afraid it’s still not quite working…

I added the line as per your instructions, but now this is what I’m seeing on mobile:

So now the text appears on the front of the card, but, where I would want a space, there is the {{c1:on my way}}.

Please let me know if there is any info/screenshots that I can provide to help you help me!

Thanks again in advance for any ideas!

Here is a screenshot for Desktop. Make sure the code is as in here:

If your issue persist, please provide a sreenshot of your HTML view of the Text Field. (in order to see that window: browser view, clock on a card, select the Text field and then the more option button (like 3 horizontal lines) and edit HTML option).

1 Like

Still not working…

This is what I’m seeing on the front now:

Do you really think we should put the table here? {{c2::Are you sure}} {{c3::it won’t be}} {{c1::in the way}}? 

Thanks, Guillem!

Because I’m a new user, I couldn’t post two images and I tried to type out the HTML code but it doesn’t look like it worked so here’s a pic… I hope!

Just tried with multiple clozes and is also working. Can you share your template view? (the one I shared)
Perhaps is unrelated, you have a slash in the notetype name Cloze/Type… , sometimes they are problematic. Try to rename it just to discard one possibility.

1 Like
Front Template

Back Template


this note type should be created from Cloze and not Basic (type in answer)

based on this, are you using Fill the Blanks - Multiple type:cloze support?

Edit: just tested the add-on myself. you’re using the add-on that’s why you can view your cards on pc but they’re blank on AnkiMobile/AnkiDroid.
Here’s how your cards will look like on pc if you use the settings that i gave you + the add-on.


I didn’t thought about this case. Good catch.

1 Like

Thank you both very much for trying to help me solve this issue!

I have re-named the card type with no slashes or hyphens - there has been no change.

Here is my current template view:

I wasn’t able to successfully download that add-on, so I just changed the text on the front card template to {{type:close:Text}} and it looked like it was working at first.

When I made the above change (adding “type:” to the Front template text), I did it from the Cloze template, not the basic (type in answer).

These seemed to be working at first… The problem seems to have arisen when I added fields (Audio and Extra Notes) to the back.

My goal here is to create multiple type-in-the-answer cards using the Cloze deletion function (this is much faster!) and to have the audio and extra notes appear on the back of the cards.

Thanks so much to both of you for helping! And please forgive me - as you can see, I know nothing about all of this, so please let me know if there is extra information that I can provide.

Thank you!


you have a typo in front template. i think that’s what’s causing the problem.
change {{tloze:Text}} to {{cloze:Text}} and see if it solves the problem

1 Like

Thank you, mmdj2! That solved part of the problem.

The cards now look perfect on mobile.

They still look like this on desktop - with the “double” question (one cloze, one type in the answer box):

Is this as good as it’s going to get? Should I just be satisfied with this and encourage my students to use these cards in the mobile version and/or just ignore the extra question on desktop, or is there some way to have these appear only as a “type in answer” card on desktop, even if they’ve been created using the Cloze template?

Thanks so much for your help!

This is the updated mobile view - it’s working perfectly on mobile now:

This is the updated back mobile view:

the cards will look normal on your students’ desktops.
go to Tools -> add-ons and disable Fill the blanks - Multiple type:cloze support. then restart anki, the cards will look normal on desktop if you do this.

1 Like

mmdj2 thank you so much! It worked!

To both you and Guillem, thank you very, very much for your help - I really appreciate it and I’m really excited to use these cards with my students : )

1 Like