Anki Forums

Type:cloze in AnkiMobile

Hey there

I created some decks with mostly type:cloze cards and while they seem to work perfectly fine on PC, they appear blank in AnkiMobile. I already tried all the recommendations I found here (e.g. making sure the option isn’t disabled in the settings). It’s actually pretty simple stuff

Translation: {{c1::X}}

Informal: {{c2::X}}
Non Past Negative: {{c3::X}}
Past Positive: {{c4::X}}
Past Negative: {{c5::X}}

Formal: {{c6::X}}

Befehl+: {{c7::X}}
Befehl-: {{c8::X}}

With the card format being nothing but:

{{type:cloze:Text}}

Am I missing something? And if so, why does it work on PC but not on AnkiMobile? :o

Maybe add another field and if you don’t want to see it, maybe wrap it in a div and add hidden attribute or use style=“display: none”, it probably will work, i.e.

<div hidden>{{cloze:Text}}</div>

{{type:cloze:Text}}

If you’re using the type-in-the-answer functionality, please make sure you’ve included another field on the front side as well.

https://anki.tenderapp.com/kb/card-appearance/the-front-of-this-card-is-blank

Unfortunately the type-in-cloze still isn’t displayed. Just as a test I deleted the “div hidden” and now it looks like that:

Frontside

{{cloze:Text}}

{{type:cloze:Text}}

Style
.card {

font-family: arial;

font-size: 20px;

text-align: center;

color: black;

background-color: white;

}

.cloze {

font-weight: bold;

color: blue;

}

.nightMode .cloze {

color: lightblue;

Backside

{{cloze:Text}}

<hr id=answer

On my PC it displays the cloze + the type:cloze now. On my mobile phone only the cloze, while the type:cloze is invisible.

I couldn’t see any note type like that in your AnkiWeb collection. Could you please point to it or provide a small sample deck I can use to try to reproduce your problem?

Here we go. Maybe I’m missing something completely and it’s obvious that it doesn’t work. I’m just confused that it’s working just fine on PC but not at all in AnkiMobile.

It’s blank on both computer and phone for me, because you do not have any prompt in the front template. My guess is you have installed some add-on that alters this behaviour. If you put {{cloze:Text}} the prompt will appear. If you’re not getting a typing box at the top, please make sure you haven’t accidentally enabled AnkiMobile’s “never type answer” option in the preferences.

Oh damn, I see. Yeah, it was probably an Add-on that made things weird. Apparently I have an Add-on that considers the type:cloze:Text a stand-alone prompt, while the usual tool requires an additional cloze:Text prompt. If I added that prompt before I deleted the Add-on, it appeared twice on my PC. Now it’s working just fine.

Thanks a lot!I try to pay more attention to whether something is done by my Add-ons or Anki itself. Especially if I keep using it on my phone, Add-ons seem to be a bit tricky to use. :smiley: