My intervals are not working and are set so randomly even when I pre set them in my options

My intervals are all over the place, showing even up to 2 years and they become random every time I restart the software. I tried changing the intervals in the options bar, tried turning on the v3 schedular in preferences, but nothing seems to be working. And it is the correct version for my mac.

This is probably Due times after a break - Frequently Asked Questions

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.