My collection/account has stopped syncing

@dae Greetings. Been many years since I’ve had to post anything on the support site. Hope all is well. My family and I continue to daily actively use Anki still after 10+ years. And I heavily promote Anki at whatever school or university I visit! Keep up the great work.

Anyhow, I did some significant editing work on my deck, including reordering many of my notes (via the update creation date add-on). These changes triggered a full sync notification. After finishing the edits/changes, I ran a “check database” and that went fine. Then I tried to sync.

It starts to sync. The progress bar for “Uploading to Ankiweb” appears. Then it goes to “Checking” and stays there until it returns an error.

The error I am getting is “Connection timed out. Please try again. If you see frequent timeouts, please try a different network connection.” Then it says, "Error details: " (with no actual error details showed).

Now, while it is saying connection timed out, I don’t think the problem is the connection. I’ve tried two different network connections, each with sufficiently strong connection speeds. Also, all of my family’s accounts are syncing, and my account was syncing prior to the edits (and the collection is the same size as it was before).

I’ve restarted Anki multiple times. Rebooted multiple times. I tried exporting my collection into a new profile and tried syncing under a new account/email address. I tried only exporting one of my single decks (the specific one that I did edits within) within my collection and then importing that into a new profile and syncing with a new account/email address. And I can’t get anything to work.

It just never finishes the “checking” stage and then returns the same error. I can only assume that something in the collection itself is causing it to not finish the checking phase. And “Check Database” is unable to fix it. While I did do a good number of edits to the collection, I didn’t do anything that I haven’t done many times in prior years.

I would love your help if you can. I’m glad to share the entire exported collection via link on a private thread.

All the best,

Please pause reviewing this support request. I am trying some additional troubleshooting. I will either update or remove this request when finished with the additional troubleshooting.

So, I both have resolved the problem and continue to face the problem. No matter what I did on my main laptop, I kept getting the same error. It just wouldn’t complete the check before the connection timed out. I tried new profiles, new accounts, new uploads, multiple connections, “Check database” and more. I tried exporting my collection and importing it a new profile and account and always the same error. (I’m running Win 11, Anki Version ⁨2.1.65 (aa9a734f)⁩, 12th Gen Intel(R) Core™ i7-1265U - 1.80 GHz, 16GB ram).

However, when I imported the deck to a slightly older and slower laptop runing Anki V 2.1.61. And created a new profile and imported the deck and tried a full sync, it worked. Then I went back to my main laptop and did a full download and it worked again.

But I wanted to see if I could replicate it. So, I tried it all the same steps of editing and updating the deck on one of my son’s accounts on my main laptop, which forced needing to do a full sync, and then the full sync worked (his deck is a little bit smaller).

So, then I tried all the same steps (updating/editing the deck) on a different son’s account on my main laptop and that full sync failed with the same error. I tried everything I could to try to get the sync to succeed, but nothing worked. Then I exported his full collection, tried it on the same slightly older and slower laptop. Did a full sync and it worked.

So, I’m just passing along what happened. I don’t know if it truly is just a timing out issue or some other deck issue. I feel a bit stupid saying this, but I only discovered after all of the above that I can adjust the network timeout amount. I have increased that in the hopes that it will prevent the issue in the future, but I’m too tired to keep testing again. Hopefully it is all resolved, but at least wanted to pass this along.

Anyhow, @dae, we’ve appreciated all your work on Anki. We have one family member at over 1.3 million reviews and another approaching 1 million. We bought an apple account to get Anki even though we don’t use an Apple device (or technically got rid of the very old device that we sitting in a drawer that allowed us purchase AnkiMobile).

Glad to hear you and your family are still finding Anki useful! Those are some impressive review histories you’ve accumulated.

A full upload needs to send the entire collection instead of just incremental changes, so it’s more taxing on the network.

It would be interesting to hear if you get noticeable differences when running the following test on the problem and no-problem laptops:

I suspect there’s something unique to the problem system like a flaky wifi card or drivers.

To test whether increasing the network timeout helps, you should be able to force a one-way sync in the preferences screen - making any modifications to the collection should not be necessary to reproduce the problem.

Thanks @dae. I feel quite a bit embarrassed, because I didn’t know until after a full day of troubleshooting that there was a user controlled setting to adjust the network timeout setting, but indeed by increasing that it seems to have solved the issue.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.