My anki stop to work on Linux Debian 12(bookworm)

Hello everyone,

I was using anki 2.1.65 on Debian 11 and it was working but now after update my linux It has stopped to work. I was using anki with Qt5, I tried to uninstall again, I tried to install anki with Qt6 but it doesn’t work too, can someone help me?
When a run it on terminal there is the fallowing message:
~$ Anki starting…
Initial setup…
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run…
Qt warning: Could not connect “org.freedesktop.IBus” to globalEngineChanged(QString)
Starting main loop…

The window displays correctly for me on a Debian 12 install here. You may find switching to software graphics helps.

Thank you very much.

I was using software graphics all along, but tried the config file with ‘software’, as suggested in the link, but it did not help. I get a menubar with the ‘File’ etc. entries, but otherwise, the window is empty. Yes, I am using the nouveau driver, as I had massive troubles with the nvidia driver and generally like Open Source better. What else can I try?

Assuming you’re using the Qt6 version, I can’t think of anything else except trying the nvidia drivers. If you’re using Qt5, it may be Blank Main Window - Anki Manual

My bad. I was running the Qt5 version. The Qt6 version works as much as the Qt5 version worked before the upgrade. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.