Need help with error message Anki 2.1.65 Debian Bullseye (Chromebook)

I need help to run the latest Anki 2.1.65 QT6 on my Chromebook. This is the error message I get when I run Anki.

name@penguin:~/anki-2.1.65-linux-qt6$ anki
Anki starting...
Initial setup...
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run...
Wayland support is disabled by default due to bugs:
You can force it on with an env var: ANKI_WAYLAND=1
  File "<string>", line 1, in <module>
  File "aqt", line 489, in run
  File "aqt", line 563, in _run
  File "aqt.profiles", line 133, in setupMeta
  File "aqt.profiles", line 413, in _loadMeta
resetting corrupt _global
Qt info: Could not load the Qt platform plugin "xcb" in "" even though it was found. 
Qt fatal: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: minimalegl, xcb, linuxfb, eglfs, offscreen, vnc, minimal, wayland, wayland-egl, vkkhrdisplay.

I tried to pass the command: anki --env=ANKI_WAYLAND=1 after reading the issue 1767. I don’t know if the syntax is correct, but no luck. I am using the original Tar package, not the Flatpack version. Debian 11 Bullseye in a Crostini container.

Thanks for your help.

After reading the missing library page, and seeing that no libraries were missing, I removed Anki and re-installed it. When I run ANKI_WAYLAND=1 anki it is working. I am happy :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.