My anki crashes whenever I go to open it

I have tried redownloading but it continues to say “Anki quit unexpectedly”. I have also tried downloading previous versions but it won’t sync with my current decks and it also will not let me use addons that I would very much like to have while using Anki. Please help!

Could you be more specific please? Which version have you tried exactly, and what were the results? Have you tried holding shift to disable temporary the add-ons (maybe one of them was causing the issue)?

Sorry I am using version 2.1.47. I attempted to hold shift but it doesn’t seem to disable temporary addons. I can’t even open the application at all without the error so not sure how to delete the addons.

Wow this seems a nasty bug, either in the use of the toolkit or in the toolkit itself (which is Qt).
Maybe try betas would be worth a shot.

Also, could you please post the whole error message (that is, everything under “Problem Details and System Configuration”).


I just tried to copy past the whole error message but the cap is 32000 characters and apparently the error message is like 150000 characters

I tried to downgrade and quit as well but I still get the same error :frowning:

Thats what you mean by beta right? I clicked on the link you posted and it told me to do that.

Is there a better way to post the whole error message?

You could try sites like, which allow you to paste the error result and share it.

Have you checked to make sure it happens even when all add-ons are disabled? When problems occur - Frequently Asked Questions