Multiple choice (10 answers) is not marking the correct answers?

Any idea why this may be? I put 1 or 2 (1 for mutliple correct answers, 2 for only one) in the correct field, and in the answers field I put 1 for correct answer and 0 for incorrect answers (eg., 1100000).

Sometimes it displays the correct answer, but most of the time it doesn’t. Sometimes it has it reversed and says the correct answer is the one incorrect answer. Other times it will have half the answers correct and half incorrect.

I do have audio in the question field and in some of the answer fields (for answers that are difficult to pronounce), not sure if that makes a difference or not.

Any ideas what could be going wrong?


Maybe try adding a space between the numbers, e.g., write 1 1 0 0 0 0 0 instead of 1100000.

1 Like

I’ll give that a try, but the example on the addon page has it without spaces.

Update: I tried it and it appears to not make a difference.

It makes a difference

When creating cards, write a “1” for correct choices or a “0” for incorrect choices in the “Answers” field. The question type can be selected with the field “QType”. It can be either 0 (Kprim), 1 (Multiple Choice) or 2 (Single Choice). The Screenshots section shows how the question types look. These values in the “Answer” field must be separated by a single space. The order and number of values in the “Answer” field must correspond with the choices “Q_1” to “Q_5”. If you don’t need all the choices, just leave the remaining “Q_” fields blank and only enter as many values as you need in the “Answers” field.
https://ankiweb.net/shared/info/1566095810

That seems to be the default behavior of the add-on (see link above)

If you want to change, then:
Tools > Add-on: Multiple Choice > Config

Then change from DEFAULT_COLORING to ALTERNATE_COLORING


Basically because you didn’t mark then

  • Correct alternative → wrong, you missed the correct alternative
  • Wrong alternatives → Correct, you didn’t choose the wrong alternative
1 Like

Thanks for the response. I tried separating them with spaces, and it isn’t making a difference. The test questions I made are showing all the answers as correct, despite the answer field having "1 0 0 0 ". :frowning:

I also tried changing the config, but the config option is grayed out on the addons list (when the multiple choice with 12 options addon is selected.)

I should add this is NOT the multiple choice add-on you linked to. This is the “multiple choice with 12 options” add-on. https://ankiweb.net/shared/info/1573325751

The author of the 12 options didn’t update with the config option unfortunately

Is 12 option necessary? The original author is still updating the add-on, but it only has 5 options.

https://ankiweb.net/shared/info/1566095810

12 options is a modified version of the one above, but haven’t been updated since 2022