Media not syncing, can't type Japanese


I’m on Linux Pop!_OS and have Anki Version ⁨2.1.56 (07fd88dd)⁩. I’ve installed Anki from ankiweb and from two separate Anki applications in the Pop! Shop. (I don’t know if there are any differences between them.) The problems I’ve run into have occurred on all three Ankis.

  1. I’ve just tried syncing from my Windows computer to a new Linux computer. The cards have synced fine except that none of the audio or images have transferred. When I click Check Media, I get “Missing files: ⁨14822⁩” The media does still exist on my Windows computer.

  2. When typing in answers during reviews, I can’t type Japanese characters. I had to install the Japanese (Mozc) keyboard which works fine elsewhere. In Anki, however, I can only type one letter on my keyboard before it freezes up. The white box that appears also freezes on the screen until I change to a different keyboard (and stays on the screen even when I quit Anki).

Not sure what more information would be helpful, as I’m brand new to Linux.

Thanks for any help!

EDIT: The white box does not appear in the screenshot, so I’m removing a photo that was in the original post.

About the first issue
try moving your media from the windows machine to your linux computer, the link below shows where this media folder is located Managing Files - Anki Manual

About the second issue, could you try doing the check add-ons step

if the problem isn’t related to add-ons, as a last resort, report to Issues · google/mozc · GitHub

(I don’t know if there are any differences between them.) The problems I’ve run into have occurred on all three Ankis.

one versions is from Debian (.deb) which is very outdated (2.1.15), the other version is from flathub (its unofficial but works, we still recommend the install from ankiweb)


Another possible solution: Japanese input with ibus/mozc buggs out when adding/editing notes

1 Like

Thanks for the reply!

Re: Missing Media: I copied the files in the media.collection folder from windows into linux using a flash drive. Now I have ⁨13359⁩ missing files (yay, improvement!). I’ll try copying the files again and seeing if I can figure out why they didn’t all move over.

Now I’m being told (occasionally) that I have to install mpv or mplayer to hear the audio–however, I have mpv installed and I can hear audio on some of the cards. Not sure what to make of that.

Re: Keyboard. I haven’t installed any Anki add-ons (didn’t even know there were add-ons!), so I don’t think that’s the problem.

I’ll also confirm that I am using the Anki version downloaded from the website:
Version ⁨2.1.56 (07fd88dd)⁩
Python 3.9.15 Qt 6.4.0 PyQt 6.4.0)

Update: I’m not sure what the problem was exactly, but I synced a few more times and have gotten all of the media that was on the Windows version to the Linux computer. Each successive sync brought more media over. Didn’t have to use the flash drive again.

I’ll look into the Japanese typing problem tomorrow.

Thanks both!

I’ve solved the problem by installing ibus-anthy. Will look at fcitx too and see which one I like better. Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.