MathJax not displaying properly when reviewing but not when editing

Dear Anki Community,

I have an issue with MathJax for some but not all Anki cards.
For some cards, equations are not being shown at all or only partically. When going to the editor to fix said issue, however, everything seems fine, as can be seen in the attached images:

Thanks a lot in advance for any help!

I believe a related issue was fixed in 23.10+.
Are you on the latest version? Please see Troubleshooting - Anki Manual

If you’re actually using the latest version, can you post the field contents?

Thanks for your reply! :slightly_smiling_face: I am on version ⁨23.12.1 (1a1d4d54):

What do you mean by “field contents”? Do you mean the equations from the screenshots shown in the original post? :see_no_evil:

Yes, as text.

Here it is:

IV: say you have  \(l\) endogenous covariates and  \(k\) instruments. What can we say about the solution? 


 \(l>k\): Z2 does not hold 
 \(l=k\): just identified  \(\rightarrow\) IV estimator can be constructed like the normal OLS estimator
 \(l<k\): over-identified  \(\rightarrow\) IV estimator has to be constructed be weighting the instruments  \(\rightarrow\) GMM/2SLS

Thank you so much for your help!

Simple copy-and-pasting would return

IV: say you have  Mathjax  endogenous covariates and  Mathjax  instruments. What can we say about the solution? 

I.e. everything in between “\( \)” is pasted as “Mathjax”.

It appears to be a syntax error in the equation. If you paste the Back text in some online MathJax viewer like MathJax Demo, you’ll see the text is truncated.

If I change \(l<k\) to \(l < k\), it displays correctly. Not familiar enough with MathJax to know why.

Thanks for looking into it!
Unforcunately, that does not seem to do the trick.
I tried changing the Anki Card accordingly, now I see the following:

The bizarre thing is: I only changed the first MathJax element, but now I see the (in)equality signes for all of the MathJax elements while the “l” and the “k” are still missing…

Also I tried the MathJax Demo and both variants work for me:

Do you have any other idea why this might happen?

\(l>k\) works without the space, but \(l<k\) doesn’t, as far as I can tell.

No idea.

1 Like

okay thanks for your help!
tbh I think it has something to do with Anki itself, not the syntax as these cards are not new and used to work just fine. But since I updated Anki this problem occured.
I have also realized that some Mathjax elements pop back up after reviewing the card a couple of times.
Maybe it would be an option to manually force Anki to regenerate all Mathjax items? Is that possible?

MathJax is rendered on demand, so there’s no separate generation step.

1 Like

okay, good to know, thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.