Linux installation

However I try, I always get an “unexpected end of file” message with the file named anki-2.1.54-linux-qt6.tar.zst

Could you please show what you do step by step, and include all the output.

Not sure if you did this, but make sure to first process the file with:

tar xf anki-2.1.54-linux-qt6.tar.zst
(Which should automatically run the appropriate decompress algo, but if it doesn’t try:
tar --use-compress-program=unzstd -xf anki-2.1.54-linux-qt6.tar.zst after making sure unzstd is actually installed).

However I tried, I just got this error message →

zstd: /stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now

This is the same error message that I got before.

In all cases, I had already installed the zstd program.
I am using Lubuntu 20.04

I hope that you will be able to find where the problem lies.

Jean-Victor Côté

Maybe you should try redownloading the archive. It seems as it’s not a valid archive, so maybe it was corrupted during download.