It's possible to insert a comma in a place where it shouldn't be possible

Tested version: 2.1.50 (dev)

Steps to reproduce: Tools → Preferences → Scheduling → Timebox time limit → insert a value containing a comma (e.g 12,7).


If you leave this field (either by pressing enter or clicking somewhere else) comma gets deleted and non-integer values isn’t inserted into app’s settings.

That’s the only field in settings with this issue.

1 Like

added to the todo list

1 Like

I believe this is just because the number is limited to between 0 and 9,999: if you want to write the number with a comma in the thousands place, it lets you do that. This also explains why it’s the only field to behave like this, since no other field has such a high upper limit.
It seems to have no effect on the value of the setting, though, luckily.

Related issue: timebox time limit input issue · Issue #1617 · ankitects/anki · GitHub