Issues with seeing images

I have recently downloaded a deck from online called Zanki, and I am unable to see the images associated with the flashcards. Every time I click I just see a tiny green hill image that is indicating that that image won’t show. I updated everything I could and I tried a few tricks on Reddit that did not work either. How can I see these images???

first, i don’t think it’s a card design issue. it’s more of a shared deck issue.
second, a link to the deck would be really helpful for users to find out if something is wrong with the deck or it’s just you having this problem.
and also, you could let us know what you have tried so we wouldn’t tell you the same things again.

anyways, are you sure that the deck has media files too? sometimes, some people might export decks without media to keep the file size small. (if your .apkg file is large (>1GB probably) it means it includes media too)
you can check your account on AnkiWeb to see if your collection has media. Annotation 2020-06-20 231656
the option to synchronize media files is disabled by default (i think) so you might have imported the deck on one device, in this way you have your media files on previous device and not on the new device.
there is also a new bug (?) in the new alpha version of anki which makes images disappear when you o certain actions but the images come back when you restart anki. (this is unlikely to be your problem tho)

I haven’t really had much issues with images/shared decks. if these didn’t solve your problem, provide some more specific info on where you got the deck from, what you have done, what you have tried to solve the problem, what device you have the problem on, etc. so other users could help you better.
sometimes really small details help people figure out what’s wrong.