Issue with deck: no such index: idx_notes_mid


I have a stange issue with some of my deck modifications, after modifying some columns of the card and changing the ordering field.
But when I try to resynchronise I have this error message :
DbError { info: “SqliteFailure(Error { code: Unknown, extended_code: 1 }, Some("no such index: idx_notes_mid"))”, kind: Other }

I’ve tried using the anki database problem solving tool but it didn’t changed anything…

Any of you had and managed to solve this issue ?
Thanks for your help !

Ok, I’ve basically solved the issue by recreating manually the index with a SQLLite DB browser, here a screenshot:

I’m using version : Version ⁨2.1.54 (b6a7760c)⁩ / Python 3.9.7 Qt 6.3.1 PyQt 6.3.1

I don’t recommend modifying the database schema in any way.


I did modify some column of the card type to add new information. All this have been made with anki features directly, I did not modify database prior to the issue.

Well after some day of usage the fix I did didn’t work correctly. Now each time I need to resynchronise the whole database because it gives me the error that it couldn’t just add the change… So I just removed the index I added in the database but now the first problem is here again.

I ended up trying to recreate database from web but I now have syncing issues.
The exact error message is: sync-sanity-check-failed = Please use the Check Database function, then sync again. If problems persist, please force a full sync in the preferences screen.

Of course I used Check Database more than once but it didn’t do anything.

I tried launching Anki with console in Windows but the console does not show any error related to that. Is there any way to have more insights about what’s going on ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.