Is there a way to force Anki to upload media to Ankiweb?

For some reason, Anki seems unable to upload some mp3 files from one of my decks to ankiweb.

I’ve searched in the forum but didn’t find anything really helpful. Is it possible to force the program to upload all the collection media to ankiweb? Any other ideas?

It should be automatic. What’s the name of one of them?

Thanks DAE. The deck in particular is Musica\Ear Training - Chords

I checked a couple of files, and they appear to have been uploaded to AnkiWeb months ago. What makes you think they are missing? What are some specific filenames that are not working for you when reviewing on AnkiWeb?

Here’s one example, but there are many more on the same deckl:

This card was made in the computer. Media file D#aug_DES.mp3 is on the computer’s media folder and, the card works fine on Anki desktop.

ID card and other info:

This is how the same card looks in Ankiweb. Sound is deactivated.

Ankiweb and Desktop are fully synced. I also forced a full sync from desktop > ankiweb, it didnt worked. I tried a full sync Ankiweb > Ankldroid, without sucess.

Perhaps the issue only exists on the files with # in the name?

1 Like

Yes, it looks like that is the problem. I’m not really sure (I haven’t used that deck for months), but I think sync used to work without problems for that deck, even for files with that character.

Should I change all files and cards or is it any other option?

Perhaps a good time to remember that # and ♯ aren’t the same thing. :wink:


The files have been synced to AnkiWeb, so if they’re not playing on AnkiWeb, it’s probably just an issue with the review screen. They have likely been synced to your phone too, and AnkiDroid likely has a similar issue with that character.

Thanks again.

I’ve done a quick test and it looks like Ankiweb is not compatible with media files containing the # character (same for Ankidroid)

I’ve solved the problem easily, just by bulk renaming all files and searching / replacing all notes, replacing # > ♯, and now it works properly both in Ankiweb and in Ankidroid.

As far as I know # is not a forbidden character for filenames, and, if I haven’t missed anything, I haven’t found any reference for this in the docs, is this normal behaviour?

It has a special meaning in web links, which the different Anki clients need to account for.