iPad_Automatically answer a cloze card without showing options

Hello,

I have been using Anki for the past six years and recently purchased the application on the App Store for my new iPad. I also bought an Apple Magic Keyboard to use with my tablet when needed.

Initially, everything worked fine, but after about a week of usage, the application started glitching. I have a cloze deck, and sometimes when I type the answer into the field of a cloze card and press the Enter button on the physical keyboard, the application behaves as if I pressed the Enter button twice. It shows me the back side of the card with a green checkmark animation, as if I pressed the Easy button (or the Enter) and instantly shows me the next card. This glitch happens randomly, and sometimes I am able to choose the difficulty of the card, while other times, the application shows me the next card instantly with the animation of if I pressed 3 button or Enter button.

I tried using the application with the virtual keyboard, and everything seems to work fine. I have not encountered such troubles in other applications, and my devices are quite new. I also checked the software version, which is 2.0.96, and it hasn’t been updated for two months. So, maybe I inadvertently turned on one of the settings and made the application work incorrectly.

I have already submitted a problem report to the store, but I don’t think I will receive quick help there. So, I decided to register here to ask for help with the trouble, which makes using the application completely annoying for me. Can you please assist me in solving this problem?

Thank you.

It’s strange that it only started happening after a while. If you force the app to close, does that make the problem go away? Close an app on your iPhone or iPod touch – Apple Support (AU)

I’ve exhausted all troubleshooting options. I closed and reopened the app, and even restarted my device. However, the problem is still persisting and very unpredictable.

This morning, I was able to study around 20 cards without any issues. However, when I returned in the evening to continue studying the deck, the issues arose. Sometimes, I would encounter the issue twice for one card, and each time I had to undo the card to choose the ease variant.

It seems like the app automatically detects which card is easy for me, automatically switches the card according to an algorithm it knows and advances to a next one.

There’s no feature like that - the closest is the “auto advance” option, which needs to be manually enabled at the start of a study session. Does updating to iOS 17 help? If it continues to happen, does restarting the app temporarily make it go away?

I’ve juste updated the system to 17.0.1 version and reinstalled the software. The problem still occurs.

Update:

I suspected that the issue might be related to a hardware problem with the keyboard, so I disconnected the tablet from the Apple Magic Keyboard and connected it to my Logitech MX Keys keyboard via Bluetooth. However, the issue persisted regardless of the device I used for input, indicating that it is definitely a software problem.

I’ve run through about 50 cards with an Apple keyboard, and can’t seem to reproduce this here, unless I hold down the enter key or double-tap it, which I presume you’re not doing. Are you using an English keyboard layout? Are you using split-screen? Does restarting the app when the problem happens temporarily make the issue go away?

Yes, I use only the English layout and don’t use split screen. The problem remains even if the app has been restarted.

Weird stuff, today I also went through about 50 cards and didn’t experience the problem at all. But today I didn’t spend much time on each card. Usually I spend about 30 sec on each card, but today since I didn’t have time to review them thoroughly, I made it much faster. So, each card took me around 7 sec to review.

Also the cards template have a little HTML markup and JS code. Nothing really serious but maybe it affects the problem occurence somehow. Please see below:

<div class="card__deckname">
      <span>
        {{Deck}}
      </span>
    </div>
<section class="card__wrapper">
      <div class="card__question">
        {{IMG}}
        <div class="card__question-text">
          {{cloze:English}}
        </div>
      </div>
      {{type:cloze:English}}
      </div>
    </section>
<script>
	var documentInput = document.getElementById("typeans");
	var PLACEHOLDER_NAME = 'answer';
	var cardQuestion = document.querySelector(".card__question");
	var cardQuestionDivs = cardQuestion.querySelectorAll("div");
    var mediaQuery = window.matchMedia('(max-width: 768px)');

	documentInput.style = null;
	documentInput.placeholder = PLACEHOLDER_NAME;
 
	cardQuestionDivs.forEach((div) => {
		var image = div.querySelector("img");
		if(div.classList.length === 0 && !!image) {
			div.parentElement.prepend(image);
			div.remove();
		}
	})
</script>

The JS is probably not related, but you could try removing it to rule it out. If an app restart doesn’t help, what if you reboot your device - does that make a temporary difference?

For the past two days, I have been practicing with a deck of around 50 cards without any issues. Prior to this, I did not restart the program or reboot the device. However, two days ago, I encountered a problem under similar conditions. It appears that the issue is quite unpredictable. I plan to continue practicing tomorrow and observe if the problem persists. Perhaps it has been resolved on its own, but I am uncertain.

I think I found the cause of the issue. For the last four days, I used the app without my Bluetooth headphones (HUAWEI Freebuds 4). But today, I decided to connect them in the middle of studying a deck. Once they were connected, the problem occured. I tried several cards from the deck: some of them worked fine, but others had this double ‘Enter’ issue.
So, I believe the Bluetooth headphones somehow affect the occurrence of the issue.

So the problem comes back when you start using them again? That is very strange.

Corrcect. The problem only occurs when using two devices at the same time. Namely, if I use a keyboard (either bluetooth or with a physical connection to the device) and heaphones.

Assuming those cards contain audio, if you turn off ‘automatically play audio’ in the deck options so audio doesn’t play, do you still see the same behavior?

They do contain the audio. I turned the option off, as you suggested and was able to study 40 cards of 50 scheduled for today with the headphones connected, without any issues. When I turned the option back on, the 41 card revealed the problem.
So, the problem occurs in the conditions when I study a deck with both bluetooth headphones and bluetooth/physical keyboard connected to the device, and when ‘automatically play audio’ option of the deck is on. If either of these conditions are false, the problem doesn’t occur.

I’m guessing that the delay as the bluetooth connection is set up is causing this. This may not be easy to fix, but I’ve added it to the todo list to try to reproduce when I have a chance.

This is most likely just a problem with the specific headphones (or the brand/ the protocols that the brand uses). I tried to reproduce the same thing with Bose QC45 and did not face any problems.
It’s definitely not the first thing to.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.