Anki Forums

Imports missing added fields

Hello, this seems like a quick fix, so I’ll try to make it short. I’ve used Anki for years now but haven’t touched it in over a year.

The new issue I’m facing is that when I try to import a file, I’m only allowed two fields. In the past, I have added in multiple fields before and have fiddled with Anki enough to know how to rectify the issue on my own, however, now no matter what I do I can’t seem to get that extra field added during the import process. However, when I try to add a new card by itself, I’m given the option to add to the ‘example’ field, the same goes for reviewing my cards in ‘Browse,’ but that doesn’t exactly help me. I want to solve this issue so that I’m not adding in multiple entries one card at a time.

I add text files with three fields, front, back, and ‘examples.’ New cards are separated by a new line, and fields are separated by a tab. I wasn’t getting this third field option during import, so I tried updating the app to the current form, but that changed nothing for me. I’ve already tried to fix it by doing the following:

  • Adding a new field into the card
  • Creating a new card from scratch
  • Ensuring the text document is typed correctly, saved as the correct type and encoding
  • Trying different profiles

Any input would be greatly appreciated.

The number of fields to select will depend on how many fields are on the top line of the file, and the field separator you have selected.

Thank you very much, that did fix the issue! But, and this is a small but, now cards without three fields aren’t included in the import. Of course, I can always write in a simple third field like ‘no example,’ but is there a way to not have to do that?

You can leave empty fields blank, but the number of separators must always be the same.