Haven't been able to sync or access cards in months due to sync fail

A couple months ago, I started getting this error every time I opened Anki:

When closed, it turns into this error:

This has happened through multiple versions (I’ve tried 2.1.49 up through the current version and downgraded to 2.1.35).

If I try to open a backup file, the user becomes inaccessible and I get this error:

(I should mention that I made a new deck as a test and I could import the backup from that file, it’s just my old deck that is unable to be accessed.)

I can still access my decks on the web and Android app but obviously I would like to use the desktop app, especially for adding cards… The only solution I can see is making my card deck public and then importing from there, but I assume that’ll wipe all my progress (and I have thousands of cards so that would really stink).

I’m using Windows 10.

I also tried deleting all the Anki files from AppData and reinstalling, but the syncing problem was still there.

Does anyone know what to do? Thanks in advance.

I can no longer edit but it turns out I had two copies of Anki installed and one of them was 2.1.5. My computer automatically loaded that one instead of the newer version and that’s what caused all my issues.