Getting error "Unable to save changes: invalid card 5" on Anki 2.1.29

I just upgraded to Anki 2.1.29, and some cards in a shared deck (World Currency) no longer display, instead showing this error:

Front template has a problem:
Found ‘⁨{{/Currency Used}}⁩’, but expected ‘⁨{{/Abbreviation}}⁩’

I therefore went to the “Cards” view and fixed the ordering of the closing fields, ending up with this:


{{#Currency Used}}
{{#Fractional Unit}}
{{Currency Used}}

Fractional Unit
{{/Fractional Unit}}
{{/Currency Used}}


{{Currency Used}}

{{Fractional Unit}}

The preview looked good for both sides of the card, no errors reported, but when I hit “Save”, it gave me the error:

Unable to save changes: invalid card 5

Some additional info that may or may not be helpful:

  • The fields for each card in this deck are: “Country”, “Currency Used”, “Symbol”, “Abbreviation”, and “Fractional Unit”.
  • There are 234 notes that use this card type - perhaps the error is on another card??
  • I am on Ubuntu 18.04.1 LTS
  • I installed Anki from the packaged 64-bit Intel/AMD Linux version on the website
  • I tried downgrading to my earlier Anki install but was informed that the deck(s) were no longer readable.

Thank you in advance for any help you can give on this.

I think the error message is telling you that you used something like {{#Abbreviation}} but without the closing expression ⁨{{/Abbreviation}}. So you should check the field called Abbreviation in the front template of your card types.

Two of your card templates have problems - you fixed one of the templates, but have a similar issue in the 5th template. You can select it from the drop-down at the top.

Thank you, that worked! I didn’t understand that “card 5” related to the 5th card template, but it makes sense now!

No problem, I’ll look into improving that error message.