Faulty Flatpak Version on Steam Deck

Hi there!

When installing Anki as a flatpak on the Steam Deck (running Arch Linux + KDE) and adding it to Steam, it generates the following launch options:

run --branch=stable --arch=x86_64 --command=anki --file-forwarding net.ankiweb.Anki @@ @@

Now when trying to start Anki on Steam will not run. I figured out how to fix it and helped a few others on Reddit who faced the same issue. Since flatpaks seem to be the future of packaged applications on Linux I would like to fix this issue asap so that other people do not need to search the web for a fix.

Apparently the problem is that Anki expects the locale to be set, which is not done by default by flatpak. You can set the locale in the steam launch options:

run --env=LC_ALL=C.UTF-8 --branch=stable --arch=x86_64 --command=anki --file-forwarding net.ankiweb.Anki @@ @@

I would like to figure out where this should be fixed:

  • Steam: Adding the locale to the default launch options?
  • Flatpak: Why is having no locale even an option?
  • Anki: How is the locale used? Having a default instead of crashing may be better?

Apparently the flatpak locale is already globally set on the Steam Deck, however it doesen’t seem to be picked up.

Since I do not really know much about flatpaks yet, I would like to get your thoughts about where is problem may be rooted.

A UTF-8 locale needs to be set, or non-Latin text will lead to errors. Please contact the author of the FlatPak and let them know of the issue.