Extended Tag Add/Edit Dialog [Official thread]

If you have a problem with the add-on Extended Tag Add/Edit Dialog post in this thread. This way I get notified. If you make a new thread I will likely miss it.

How to slow down the demonstration video in Windows 10?

You can download the screencasts (gifs) by right-clicking them. Then select “save image as” from the context menu (tested in Chrome and Firefox). Then open these gifs with a program that supports to pause gif files.

On Windows I use the popular image viewer IrfanView that can also display gifs. IrfanView has “Options->Start/Stop Animation” and you can adjust the speed with [SHIFT][CTRL][+] or [SHIFT][CTRL][-]. On Linux I use mpv.

But everything of this screencast is also in the anking youtube video linked from the first line of the description.

1 Like

Thank you.

Hi ijgnd,

thank you for making this add on. I’m having a problem with the keyboard shortcuts. No matter what combination of keys I use nothing happens when I click them. I found this from the AnKing video for medical school and it seems great I just can’t really use it. I verified that all of my keys work on my laptop. Any ideas?

@RandyS: You don’t offer enough info to give a real answer. Some points:

  • After changing the config of an add-on you should restart to make sure that the changed config is used. Many add-ons sometimes apply the new config without restarting but you can never be sure. So: have you restarted anki?
  • There can be interactions between add-ons. Disable all other add-ons and restart Anki, then try to use my add-on. If it works then you know it’s an add-on conflict. Then I would reenable only half your add-ons, restart and try again. If it still happens disable half of those so only a quarter is enabled, restart and try again. If it works enable half of a quarter so that 3/8 of your add-ons are active. So with a few steps you should be able to find the add-on that causes the problem.
  • Maybe you have problems with the new style two part shortcuts? Change the shortcut of my add-on to a shortcut from another add-on you have that you know works. Naturally this other add-on must be disabled. Restart Anki. Does it work now?
  • If it still doesn’t work have a look at https://anki.tenderapp.com/kb/problems/when-problems-occur . Maybe updating to a newer anki version helps.
  • if the problem persists even on 2.1.30 without other add-ons: from the main window click on Help->About. In the window that opens click the “Copy Debug Info” Button and share the copied text.

Hi, currently it is “Ctrl+6”, should I be hitting the plus button along with control and 6? I’ve made sure to restart when changing the config.

@RandyS: If you have “Ctrl+6” you don’t have to press the plus button. It’s similar to e.g. “ctrl+b” to make selected text bold.

Also: Reset the add-on config (in bottom left of the config window), and then change the shortcut to “Ctrl+6”. You might have assigned “Ctrl+6” to an old, unused key. The config keys changed about 6 weeks ago.

Truly amazing addon! realized today that sadly this addon does not work with “Speed Focus Mode (auto-alert, auto-reveal, auto-fail)” addon. But not a big deal, although it is commonly used by the medical school community.


does not work with “Speed Focus Mode"

I don’t use Speed Focus Mode. I just installed it and didn’t get any error messages. But when I open my tag add window the timer continues for the reviewer window and rates there so that in effect you really shouldn’t open my tag add/edit window from the reviewer when you use Speed Focus Mode. Is that what you mean?

In the reviewer you could press “e” to go to the edit current window. This should stop “Speed Focus Mode”.Then you can use the editor shortcut of my add-on “Ctrl+t,d” by default to open the tag dialog. After closing this dialog use “Esc” to close the edit current dialog. So you need two additional shortcuts.

That’s not ideal, especially if many people have to use this workaround. But it saves me a lot of development time: I could try to adjust my add-on to glutanimate’s current version but this requires extra work whenever he updates his add-on. Also any change I make now might break other stuff about my add-on.

This add-on does not work with add-on “Card browser: List only one card per note” which shows only one of the cards of a note in card browser. When I use that add-on and click a card (=note) in card browser, then type shortcut (Ctrl+t, d), Anki shows a message “only works if one card is selected”

@DmitriyDotsenko: Thanks for reporting this problem. I can confirm it.

I have just uploaded a new version of the add-on to ankiweb that should fix this problem. I also included multiple other small changes collected over the last year.

Could you update, restart Anki, and try again. Let me know if you find any errors.

@ijgnd, thank you for prompt action! Everything works fine now

@ijgnd Hey! Thank you for creating this add-on. It is exactly what I have been looking for. Unfortunately, it does not seem to be working with my Anki version 2.1.44. I am selecting cards within the browser, and I have tried using all permutations with Ctrl+ etc. None of them seem to be working. I have disabled all other add-ons. I am pasting the debug information below. Please let me know your thoughts when you get a chance! Thank you!

Anki 2.1.44 (b2b3275f) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.16
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-08-06 08:47:01

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Extended Tag AddEdit Dialog ['1135507717', 2021-05-18T19:29, 'None', '']

===IDs of active AnkiWeb add-ons===

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
AMBOSS Official  Medical School Step  Shelf Study Resource ['1044112126', 2021-07-26T05:47, 'None', '']
Advanced Browser ['874215009', 2021-07-22T16:14, 'None', '']
BetterSearch ['1052724801', 2021-05-18T19:30, 'None', '']
Button Colours Good Again ['2494384865', 2021-04-06T09:57, 'None', '']
Clickable Tags v20 Anki 2120 support ['1739176371', 2020-03-13T09:25, 'None', '']
Create Filtered Deck from the Browser ['861263371', 2017-08-29T13:57, 'None', '']
Custom Background Image and Gear Icon ['1210908941', 2021-08-05T11:58, 'None', '']
Hierarchical Tags 2 ['594329229', 2021-03-06T20:25, 'None', '']
High Yield Tags ['1918380616', 2020-06-30T15:35, 'None', '']
Image Occlusion Enhanced for Anki 21 alpha ['1374772155', 2020-04-27T21:21, 'None', '']
ReviewHeatmap ['723520343', 2019-08-03T10:14, 'None', '']
Special Fields ['1102281552', 2021-06-20T16:27, 'None', '']
Symbols As You Type ['2040501954', 2021-03-21T21:17, 'None', '']
Symbols ['1461102936', 2019-04-18T15:21, 'None', '']
True Retention ['613684242', 2017-11-19T14:43, 'None', '']
right hand reviews  hjkl answer shortcuts  Handy Answer Keys configurable ['850294128', 2019-12-21T17:40, 'None', '']

@ijgnd Please disregard my above comment! I have adjusted the syntax to “Ctrl+6” as suggested above, and it works when all other add-ons are disabled. I will systematically re-enable these add-ons to see if there is a problem. Thank you!

The only keyboard shortcut that works for me is “p” in the reviewer. No shortcut works in the browser. I followed all the steps you suggested to “RandyS”.
I tried:

  • changing the configs and restarting anki
  • disabling all other add-ons and restarting anki
  • I watched the video section you posted in another chat about how to use two part short cuts. for example (for ctrl+t,d) i hold ctrl and t then hit d.
  • I went through the link for “when problems occur” you posted and tried some of their suggestions.
  • My version is 2.1.40

Really don’t know what else to do at this point?

@infinitejest: it’s very useful that you provide so much info in your bug report.

when it comes to problems/bugs there are always two reasons: Either its the software/add-on or its you (the user who makes a mistake).

on the one hand doing the checklists substantially raises the likelihood that there’s a problem in my add-on (and in general sometimes popular add-ons are broken for days or weeks). But in this case: the version of extended tag dialog has been on ankiweb for over four months and so far I haven’t gotten such a bug report and for this add-on there are some diligent people who quickly report bugs. So maybe (and hopfefully for me) the problem is on your side.

two part short cuts. for example (for ctrl+t,d) i hold ctrl and t then hit d.

these shortcuts are unusual and it’s easy to get them wrong. To rule this out: when all other add-ons are disabled could you reconfigure the extended tags add-on so that e.g. "open tag lines dialog: from editor" uses a simple shortcut like “Ctrl+6”? (or if you use macos it’s "cmd+6" as far as I know).

Does such a simple shortcuts work?

Another idea: enable one other add-on of yours and configure it to use the shortcut “Ctrl+t,d”. After a restart: Does the shortcut work for the other add-on?


In general about a shortcut like “Ctrl+t, d”, it’s “ctrl down”, “t down”, “t up”, “ctrl up”, “d down”, “d up”. So you release the ctrl (or cmd on mac) before you hit the second key.

Which OS do you use? Win-Mac-Linux?

Please make it so you can scroll through if the tags take up the entire screen.

@DoctorToBeIn23 : Thanks for reporting this. I didn’t anticipate this use case. This should not occur.

Could you test a new version you can download from Release extended_tag_edit__2022_03_10 · ijgnd/ankiaddons_for_testing · GitHub (check the end of the file name for the anki version supported by each file, i.e. 10-19, 20-49, or 50+)

Besides this change I reorganized the code which might have introduced bugs to the old code.So could you test all functionality of this add-on.


Some background info for me:

Making the tag list scrollable was more complicated than expected. My add-on so far uses a QVBoxLayout which doesn’t automatically add a scrollbar. For this there is the qt widget QScrollArea. But as far as I see QScrollArea does not work well if you put a layout with multiple widgets into it. Switching between widgets (lines) so that a widget that’s not visible didn’t automatically move the scroll bar.

So I tried a different approach: Instead of using a QVBoxLayout containing multiple QLineEdit-Widgets I switched to using one QListWidget. This widgets adds a scrollbar as needed and adjusts it automatically based on the line you’re in.

But I ran into multiple problems with the QListWidget: My keyPressEvent listener doesn’t work anymore: In my old add-on pressing space or return key meant a jump into a new blank line at the bottom. At the moment I can’t figure out why my code doesn’t work in the QListWidget - I added some comments into the source code.

But in general I like the automatic handling of space and return.

So I combined these two approaches: If only a few tags are shown the old code is used, if you have many tags the QListWidget is used and there’s no automatic handling of space and return. The upside: If you have many tags at least you have a working window. To distinguish between those two modes I added a new setting named “dialog type: scrollable if more tags than”

1 Like

This works, sorry I missed this notification