Errors when updating Anki! Can’t access Anki anymore!

Hi, today when I opened up anki, I got a message saying there was an update.
I downloaded the update, but when I was installing it, it gave me the error “Error opening file for writing: C:\Program Files\Anki\d3dcompiler_47.dll”.
I tried reinstalling, but it kept giving me the same message. When I tried opening Anki up, it gives me the message “Error loading Python DLL ‘C:\Program Files\Anki\python38.dll’. LoadLibrary:The specified module could not be found.”
I even tried deleting Anki to reinstall it, but it says it can’t find it…
I don’t want to lose my progress on my decks on Anki! How can I solve this issue without erasing my progress?

1 Like

PROBLEM: I am having a similar issue on my Google Pixelbook as of this morning.

OPERATING SYSTEM: I am running the Crostini Linux OS on my chromebook to run the Linux version of Anki. I have used Anki for the past 2 months on Crostini just fine. I updated my Anki to the latest version (2.1.33) today and since then I can no longer run Anki. Now I get an error messages that says:

Traceback (most recent call last):
File “runanki”, line 3, in
File “/home/dae/Local/py514/lib/python3.8/site-packages/PyInstaller-4.0.dev0+g2886519-py3.8.egg/PyInstaller/loader/”, line 625, in exec_module
File “aqt/”, line 22, in
File “/home/dae/Local/py514/lib/python3.8/site-packages/PyInstaller-4.0.dev0+g2886519-py3.8.egg/PyInstaller/loader/”, line 625, in exec_module
File “aqt/”, line 16, in
ImportError: cannot open shared object file: No such file or directory
[1623] Failed to execute script runanki

TROUBLESHOOTING I’VE TRIED: (1) I tried uninstalling the Anki 2.1.33 and reinstalling it, but that did not work. (2) I also tried uninstalling Anki 2.1.33 and re-installing version 2.1.26 and even that did not work.

Please help or shed light on the issue. As of now, I cannot use the linux version of Anki on my laptop and I NEED it for med school.

Please see 2.1.29: "Error loading Python DLL." on Windows 10

Idk if this helps at all, but I used this to fix my issue. Maybe it would help you too.
Go to and read “Install problems”.

1 Like

A cursory Google picks this up:

1 Like

Thank you. Using the script below the script fixed my problem.

sudo apt-get install libnss3